C-Command Software Forum

Losing focus from the viewer?

I think I may have found a small bug, that I am able to reproduce.

I read many web archives inside EF, and trash them (using cmd-delete) moving to the next archive while keeping the focus in the viewer window, allowing easy scrolling there using the arrow keys.

I’ve noticed that if the next file is something that cannot be scrolled (in my case a .flv file set to open with VLC, thus displaying as a VLC icon), if I cmd-delete, then upon hitting the scrolling key I get a “bip”. If I cmd-ctrl-arrow switch to another record, I still get the “bip” and cannot scroll.

To get back the focus where I need it I need to click inside the viewer pane, or tab until I get the focus there.

What is a “bip”? Which “scrolling key” are you pressing?

I’m not seeing a problem on my Mac (running 10.5.2). I start out with a Web archive selected in the list, and the focus is in the viewer. I press Command-Delete, the Web archive moves to the trash, and a .flv file becomes selected. The viewer still has focus, and there’s nothing to scroll, so pressing Page Up or Page Down plays the beep sound. That seems correct to me.

If, instead, the focus starts out on the records list, it stays on the list, and then I can scroll the list.

By “bip” I mean that the computer beeps.

I’m pressing the arrow keys to scroll.

The behavior you describe is what I see as well. The problem is if I move up to another web archive, then I also cannot scroll it even though I should.

Let me explain how I can reproduce this:
I have 2 web archives (WA1 and WA2) and a flv file. I’m reading WA2, WA1 is above, flv is below. The viewer has focus and I scroll using the arrow keys.

I then erase WA2 (cmd-delete), the record shown is now flv, and if I use the arrow keys, I get a beep. I crtl-cmd-up to WA1, and I try to scroll. But I still get a beep and I cannot scroll using the arrow key.

What I also find strange is that if I click on the flv record and click to move the focus to the viewer, failing to scroll with the arrow keys does not result in a beep.

I hope you’ll be able to reproduce it,

Alan

OK, I can reproduce this. Thanks.

This is fixed in EagleFiler 1.3.2.