C-Command Software Forum

Mac OS 10.15 Strange Behavior

Hi Folks -
Have loved this plugin for awhile, but with the 10.15 update, I’m getting some weird results, and search as I might, I can’t find a solution.

I’m using Mac Mail, and have about 8 email accounts. Spam Sieve seems to be working fine on all of them except my gmail account. Email comes in to that account, and DOES get filtered by SpamSieve into the Junk mailbox, but it also stays in my inbox. This didn’t happen before.

Oddly: When I look at my email on another computer, also using Mac Mail, but not using Spam Sieve, (but with the other computer running Mac Mail, and actively filtering emails), I can see email come in to my inbox (gmail account), and then disappear a few seconds later. So Spam Sieve is working, and it seems to be telling the server to move the message, but it is leaving a copy behind on my main computer.

I’m tried completely deleting the gmail account from my computer and setting it up from scratch, and I’m getting the same result.
Again, everything seems to be working normally on other email accounts going in to the same computer, as far as I can tell (but they get much, much, less junk than my gmail account, so it is hard to be totally sure…)

Any ideas?
thanks!
j.

SpamSieve identifies the spam messages, but the moving part is handled by Mail itself. Unfortunately, there seems to be a bug in the Catalina version of Mail (only affecting certain customers) where the messages don’t move or move but also stay in the inbox. Gmail accounts are predominantly the ones affected.

Some workarounds that may help:

  • Set up the Gmail account in Mail as a regular IMAP account, e.g. choose Other Mail Account
    instead of Google when adding the account.

  • In the SpamSieve rule, select a Spam mailbox that’s within the same account as the one whose messages aren’t moving.

  • Click this link to tell SpamSieve not to mark the spam messages as junk on the server.

  • Use the script rule workaround.

Thanks!
I tried all four methods, and the last one (script method) seems to have worked. Or maybe it was a combination of all 4. Either way, works now.
thanks a bunch!

j.