C-Command Software Forum

Mail disabling SpamSieve filters?

This is a problem I encountered a while ago, and has started recurring again (twice in the past week). My searching hasn’t brought up other people encountering it, though.

I have SpamSieve 2.9.27 running on a headless Macmini6,2 [macOS 10.12.2 (16C67)], Mail 10.2 (3259). Sometimes I start noticing junk coming through into the inbox. When I check, my SpamSieve Mail rules (for all 4 accounts I’m running it against) are disabled, and the “Account is <Account>” match criteria has had the “<Account>” unselected. (Which came first, losing the account or being disabled? Don’t know.)

This seems to usually happen overnight, but I can’t guarantee it. I do not have any custom scripting running against Mail, although I do have iCloud’s Mail sync enabled.

Any ideas or pointers would be incredibly welcome.

Thanks.

When the first pop-up menu is set to Account, the second one (at least on my Mac) only contains accounts. There is no “none” setting. So when you say that “<Account>” is unselected, what is Mail showing as selected instead?

I haven’t heard of this particular problem before, although I have seen Mail disable rules when either the criteria or actions are no longer possible.

I would look at unchecking the System Preferences > iCloud > iCloud Drive > Options > Mail syncing. It might be that another Mac that doesn’t have those same accounts is messing up the rules, and then they’re syncing back to the Mini.

When the first pop-up menu is set to Account, the second one (at least on my Mac) only contains accounts. There is no “none” setting. So when you say that “<Account>” is unselected, what is Mail showing as selected instead?

The second popup just shows as a white lozenge. Clicking it reveals the accounts, which I can then select to re-enable.

I would look at unchecking the System Preferences > iCloud > iCloud Drive > Options > Mail syncing. It might be that another Mac that doesn’t have those same accounts is messing up the rules, and then they’re syncing back to the Mini.

Will do. That seemed to be the only reasonable possibility, but thought I’d check whether anyone else had more insight. Sure wish console logs were useful.

I was just about to create a new topic reporting that since I upgraded to Sierra (just 2 days ago) I’m getting a horde of spam in my inbox. This post reminded me to check the rules - and sure enough, the SpamSieve rules were unchecked.

And I’ve never had iCloud’s mail sync enabled.

I do now vaguely recall that this may have happened before after a major OS upgrade … ?

It doesn’t normally happen, but sometimes Mail does lose track of which rules are enabled.

Oh right. Interesting to know. Thanks Michael.

Still happening
The mail rules have been lost 3 times since I last posted here: I had turned off Mail iCloud sync on the mail server Mac mini.

The first time seems to have been due to logging in to a new mail account on a different machine (logged in to the same iCloud account). The second and third time have been due to simply rebooting the non-server laptop. I do have Mail sync checked on the laptop.

So now I’ll have to disable Mail sync on the laptop and try a reboot, but might be a few days before I confirm yes/no on the behavior.