Mail headed to SPAM box AND stays in INBOX

Running AppleMail under Mojave. Spam filter is on the top sending everything to on my Mac spam box. Pulling mail from both a gmail account and a private domain I own. Though not sure with my private email account, but with Gmail, stuff that could be spam ( still training) ends up in SPAM box, but ALSO STAYS in INBOX for gmail. Obviously, I do not want to have to toss the same mail from two both boxes. I THOUGHT SpamSieve would MOVE the spam to the SPAM box NOT COPY it as it seems to be doing.
thank you in advance-

Please check your rule in Apple Mail to make sure that it’s set to Move Message rather than Copy Message.

Also, please choose About This Mac from the Apple menu. Which version does it say that you have?

The rule is set to copy. Running Mojave 10.14.6.


Great, then changing it to Move Message should fix the problem.

Oops. I MEANT to say, it was NOT copy and was set to move. My apologies.

Does not appear to be putting ALL emails in SPAM and INBOX. Of the last three in, one rose colored, one blue and one grey ( NO idea what the colors mean) only the ROSE colored one showed up in BOTH SPAM and INBOX. The gray and blue were ONLY in SPAM. Not sure if that helps. So far, have only seen this happening with Gmail, not with my emails. I hope to move the SPAM folder to the gmail server, though Apple Mail does not see the SPAM box in Gmail for some reason, I would have to create one.


The colors tell you how spammy SpamSieve thinks the message is.

You probably have Apple Mail configured to show the Gmail Spam mailbox as Junk. This can be adjusted in the Mailbox Behaviors account preferences.

Adjusting the SpamSieve rule to move the messages to a server mailbox instead can sometimes work around Mail/Gmail problems in moving messages.