C-Command Software Forum

Mail import f1 only importing some emails

Apologies this may be answered somewhere in the forums but I haven’t located it.

If I import emails to Eaglefiler from Apple Mail using f1 key, it imports them into a few 'INBOX’es. I assume they are per email account which I can then merge together in eaglefiler, but it isn’t importing all emails, so I have no confidence that I can delete them from Mail as well. For example tonight I’ve imported over 500 emails but of the top 4, only 2 are imported.

One is a thread to several people, the other is an email someone sent to themselves with a lot of BCCs (of which I am one). Are either of these a condition which would prevent the emails being imported?

If I try to import again to Eaglefiler later will it create duplicates of emails overlapping the first import? If so, will it remove them if I merge all mailboxes?

Thanks

EagleFiler only skips messages that are exact duplicates of other messages in the same mailbox or messages that are marked as deleted. (Normally, deleted messages don’t even show up in Apple Mail unless you choose Edit > Show Deleted Messages.)

Please note that EagleFiler imports the messages that are selected in Mail. If you are looking at a mailbox that has 500 messages, but you only select 2 messages, it will only import those 2.

If this doesn’t explain what you’re seeing, please send me some screenshots and a diagnostic report (created right after the incorrect import) via e-mail so that I can look into what might be happening.

If you import again and get a different number of messages in a given mailbox, you will get a second “copy” of that mailbox with all the messages from the second import. Merging does not removing duplicates. However, you could simply delete the mailbox from the first import.

Thanks. I’ll keep tinkering.

Hard to be certain now if it’s putting emails in several ‘inbox’ whether they are all there. I deleted the lot and tried to import again.

Still not sure it hasn’t missed a few emails but I’ll keep an eye out next time I do it - won’t be for a while now. What I do/did was pick a date, pick the last email on that date and highlight that all the way to the last email and import via f1. When imported I delete all emails, but in practice it doesn’t seem to import.

I realised this last time I did it months ago, finding out only later that some emails I needed to find were not in archive.