C-Command Software Forum

Mail import - unsupported file type?

All- I just tried to import a large maibox from Mail and got about 25 messages, to wit: “Unsupported File Type: 14360.emlx EagleFiler does not know how to read this type of file.”

First of all, what the heck is this file type, anyway? I see it during my SuperDuper! backups too, but never paid attention to it. Second, does this mean my mail is not being accurately captured in EagleFiler?

Thanks in advance.

Eric

Default Mail import - unsupported file type? More details
Okay, I’ve figured out that .emlx files are just the actual emails (right?). But I don’t understand why EF is hiccuping when trying to do the capture. Basically, I’ve got nested mailboxes with rules moving the email to the appropriate place. My mail structure looks like

Writing
-Project A
-Project B
–Project B from company X
–Project B from company Y
-Project C

and so on.

These are all populated via rules from several “on my Mac” inboxes (one for each of several ‘identities’ I use).

The problem occurs when I select a box with nested sub-boxes and try to capture it. It seems (I think) to capture the top-level box okay, but the errors must be occurring when it tries to capture the subfolders.

Thanks.

Confused-in-Cleveland (but at least the Browns actually won today!),
Eric

Right. An .emlx file is an individual e-mail message (or part of one).

I don’t either. This should work, and I just tested it successfully on my Mac.

Is the mailbox that you captured blue (rather than white)? Could you click on the Reveal In Finder button in EagleFiler’s Errors window (when one of those errors is selected) and tell me where the revealed .emlx file is? For example, if you tried to capture mailbox ProjectB, is it in:

~/Library/Mail/Mailboxes/Writing/ProjectB/

or:

~/Library/Mail/Mailboxes/Writing/ProjectB/ProjectBFromCompanyX.mbox/Messages/

or in:

~/Library/Mail/Mailboxes/Writing/ProjectB.mbox/Messages/

? My hunch is that it’s something like the first location, and that these are orphaned .emlx files that are loose in the folder, which are not actually part of one of the mailboxes and which don’t appear in Mail.

Man, I hate it when that happens! I was going to get you some screenshots, but I happened to run a repair permissions and the problem went away. Seems to work fine, now. But, in case it recurs:

  1. The folders are all blue (all of mine are-- is this bad?)

  2. The messages are all in paths like
    ~/Library/Mail/Mailboxes/Writing/ProjectA.mbox/Messages

  3. When I checked the “unsupported” files they are actually valid messages that do appear in Mail, not orphans.

  4. I don’t know if this matters, but there are messages in the Writing folder as well as in the subfolders. What would result in EF was a capture of those messages, while the subfolders would show up but be empty.

Again, it seems to have resolved itself after three days of weirdness, so it’s obviously my system and not EagleFiler. But if it happens again I’ll send you screenshots, which are probably the easiest way to see what was going on.

Thanks for the quick response, and sorry for the bother.

Eric