C-Command Software Forum

Mail Indexing Stalling

EF 1.87
macOS 10.14.4

I am trying to import a Mailbox which has 4,593 items and the records are created successfully.

The activity window shows steady progress on indexing until the count reaches 1,656 and then it stalls. I left EF open overnight but no progress was made. Closing and reopening the Library made no difference: indexing remained stuck on the same count.

I deleted all the records and re-imported the mailbox, but with the same error; steady progress until record 1,656.

I note that in the library files folder I have a monster sized text file named after the mailbox (1. SEN Links). Is this the imported mailbox?

Grateful for any suggestions.

Many thanks.

Are you seeing the 4,593 records in EagleFiler? What you wrote below makes it sound like some of the messages imported as a single giant text file rather than as a mailbox…

If you are importing e-mail messages that are in mailboxes, there is a separate indexing progress bar for each mailbox. The general one for “records” is only for the non-mailbox files. It’s not clear to me which you are referring to here, but it sounds like the latter. However, I’m not sure because EagleFiler indexes records in random order so I wouldn’t expect it to get stuck on the same number twice.

If you give EagleFiler a text file that is not a valid mailbox file, it will import it as a text file instead of as a mailbox. This usually indicates a bug in the app that created the “mailbox” file. Where are you importing this mailbox from? Are you able to share it so that I can investigate what EagleFiler doesn’t like about the format?

Giant text files can also block indexing progress because it takes too long (or your Mac doesn’t have enough RAM) to index them as a single record. The next version of EagleFiler will work around this problem.

I am trying to import one Mac Mail mailbox (1. SEN Links) which is stored locally on My Mac. I have had the same result whether I have:

  1. Selected just the Mailbox name in Mail and captured with F1.
  2. Highlighted all the Mailbox items and captured with F1.
  3. Exported the Mailbox to a MBox and imported that into EF.

Screenshots below show EF and EF Library.

If you give EagleFiler a text file that is not a valid mailbox file

I gave EF a mailbox in Mac Mail to capture, as above.

Are you seeing the 4,593 records in EagleFiler?

There are three records at the top level (“Records”) - see Screenshot.

I can view all the messages in the EF created mailbox “1. SEN Links” (see screenshot). I can view these using Quick Look. I can access any attachments to the emails if I open the message in Mail. However, I am not sure if I am actually opening the source email still stored in Mail’s library, or any copy held by EF in its Library.

Are you able to share it…

Yes. Will email you a Dropbox DL link

Screenshot 2019-05-20 at 06.33.15.png

Screenshot 2019-05-20 at 07.03.50.png

Screenshot 2019-05-20 at 06.29.41.jpg

Screenshot 2019-05-20 at 06.29.41.jpg

Screenshot 2019-05-20 at 06.29.41.jpg

It looks like I was thrown off by your description of the giant text file. Based on these screenshots, that was only in the Finder, which is normal. It looks like a mailbox with messages in EagleFiler, so the import seems to have gone well, the mailbox structure is intact, and the only problem is that indexing is getting stuck.

When you double-click in EagleFiler, it creates a copy of the message from the EagleFiler mailbox file and asks Mail to open that.

Great! It may also help to follow the “Hangs During Indexing” here.

Will do. Many thanks for the excellent support, Michael.