C-Command Software Forum

Mail macOSX Sierra Import messages script problem?

I have been using the Import from Apple mail script:
http://c-command.com/scripts/eaglefiler/import-from-apple-mail
for long time and it worked really well,
BUT, after yesterday upgrade to macOSX Sierra I am getting errors when I try to grab e-mails which contain attachments. I get in EF “Errors” window:

“Missing Apple Mail Message Attachment” and message_number.partial.emlx

Interestingly, this seems bit unreproducible. I even grabbed message once with no problem and then, later, the same message with the problem. When I open the message which showed missing part from EF in Mail again, the attachments show with arrow as they need to be downloaded.

And I checked that in the “Manage” on the About this Mac>Storage in Mail I am downloading all the attachments.


Also, if I use smart folder and display the messages as “Conversations”, in 10.11 Mail the script grabbed messages for all the Conversation (Inbox and Outbox content), but in 10.12 it seems to grab just the top, last, Inbox message, ignoring the other ones. That is quite inconvenient.

Seems Apple has done some serious under the hood changes?

Michael, can you, please, look into this and see if the script can be updated somehow or else fixed?

Are you sure? That looks like an error that you would get from importing with the capture key, not the Import From Apple Mail script.

In Mail’s preferences, does each account have “Download Attachments” set to “All” as described here?

It sounds like Apple may have broken the AppleScript property for getting the selected messages. Are you using the classic or widescreen layout in Mail?

You are right, my mistake. I use practically always option-F1 and got confused by similar shortcut (cmd-F1) I set for the Apple script import. I use the F1/opt-F1 capture as it captures as mailbox… But this F1/option-F1 used to work and is not working with attachments.

Yes, I already checked that all accounts are set to download all attachments to make sure. And now verified. This account is Exchange, so there may be yet new incompatibility between whatever Exchange my employer is using and Mail.app. BUT I sent message with 4 attachments to my iCloud e-mail and tried import that one and got same behavior.
Happened also with e-mail I was sending out - I imported Sent message and got the same error about missing partial emlx.


I take that last report back - it seems to work. It is very confusing when message is included and when not. Apple Mail shows messages in “Conversation” even though the Smart Mailbox I am using is set to show emails only in Inbox and Sent. Therefore it looks like I see 4 messages, from which F1 imports only one or two. But the other two are already archived and while they show in Mail view, they are not imported. I guess that is correct behavior. Confusing, but correct. And can be easily fixed. So the last part is my mistake, sorry. That is working.

It looks like in some cases Mail stores attachments differently in macOS 10.12, and so EagleFiler is not finding them. If you e-mail me, I can let you know when I have a fix ready to test. A workaround is to move or copy the message to an “On My Mac” mailbox before importing, or to use the script instead of the capture key.

I think this is fixed in the public beta.

Hi Michael,

I’m running EF 1.7.1 on OSX 10.12 and encountering the same issues with regards to Capturing Email.
Specifically, the Missing Apple Mail Attachment .partial.emix error.

Do you have another version of your software that I could try?

Please try the 1.7.2b1 public beta.

Thanks Michael. Works perfectly again with this latest beta.

This is fixed in EagleFiler 1.7.2.