C-Command Software Forum

Mail still not showing SpamSieve commands

I’ve repeated the steps in “7.13.2 Why don’t I see the SpamSieve commands in Apple Mail’s Message menu?” three times and still am not seeing the SpamSieve commands in Mail.

I had previously had a Scripts icon at the top of my screen when using SpamSieve in Outlook for Mac. That’s where the SpamSieve options were for training as good, junk, etc. Having changed to Mail, that no longer seems to be the case, but the menu options shown in the instructions still don’t appear.

Please advvise!

With Apple Mail, the SpamSieve commands should be in the regular Message menu at the top of the screen, rather than under a separate Scripts icon.

If you go to Mail ‣ Preferences ‣ General and click on Manage Plug-ins…, does it show SpamSieve.mailbundle as checked? Are you getting any error messages related to the plug-in when you launch Mail?

It does show the bundle checked, and no error messages.

This screenshot shows InboxSpamSieve, which carried over from Outlook. However, it doesn’t catch anything and hasn’t since I switched to Mail.

Okay, I found the Spam Sieve “train as” menu under the drop down, and this time, it did ask me for access to my messages.

Good. If you are no longer using Outlook, you can delete the InboxSpamSieve mailbox (if empty).

It looks like Mail might not be configured to use your server junk mailbox. I suggest that you go to Preferences ‣ Accounts ‣ Mailbox Behaviors. What’s selected next to Junk Mailbox? Is it something in your snet.net account or something under On My Mac? If the latter, I think you should select Bulk Mail from the pop-up menu; it should then disappear from the mailbox list, since its contents will be shown under Junk.

In order for SpamSieve to filter your mail, you need to have a SpamSieve rule in Mail, as shown in Step 3. Then the incoming spam messages should get moved to the Junk mailbox at the top of the list.

All of that is done, but SS is still not working.

When you first see the uncaught spam messages on your Mac, are they in the inbox and marked as unread?

You can test your Mail rule setup by following the instructions at the bottom of this page.

I can also help check your setup if you send in a diagnostic report.

Thanks for sending the report. It looks like you have not completed the setup in Apple Mail. In particular, you need to create the SpamSieve rule in Step 3 and turn off Mail’s junk filter in Step 6.

I did that, but it’s still not catching junk mail, even on senders I’ve marked as “train as junk.” I don’t see the SpamSieve folder the way I did in Outlook, though its commands are under the drop-down Messages menu. Any advice?

When you first see the uncaught spam messages on your Mac, are they in the inbox and marked as unread? Please send a new diagnostic report, and I’ll see what happened with the message that you trained.

There is no separate SpamSieve folder in Mail. It uses the standard Junk mailbox, which is visible near the top of your screenshot.

SpamSieve Log.log (963.0 KB)
SpamSieveHelper Log.log (474 Bytes)

If you need other files, let me know.

Thanks for sending the log files. Since you only attached the log, rather than the Diagnostic Report.tbz file, I cannot see how you have the rules set up. However, based on the log, I can see that Mail has not sent SpamSieve any incoming messages for analysis, which generally indicates that either there is no rule, that it’s not active, or that it’s not at the top of the rule list. So I recommend that you check Step 3 of the instructions again or send screenshots of your rule and the rule list if you have questions about how they should look.

So it is checked…

Your screenshot is showing that the SpamSieve app is checked under Full Disk Access in System Preferences. That is Step 1 of the instructions. Please see my previous post where I have a screenshot showing how you need to have a rule in Apple Mail (Step 3) and that it should be at the top of the rule list (Step 4) and checked.

I believe the problem is fixed and SpamSieve is now working. Thank you so much for hanging in there with me (for the second time!).

1 Like