C-Command Software Forum

Mailmate + SpamSieve (automatically runs Mail.app on launch)

Hi,

I am not sure if it is just me or anyone else has seen this. I am running the latest macOS (10.14), latest MailMate (1.12) and latest SpamSieve (2.9.33).
After upgrading the OS and everything, when I open MailMate (my MUA of choice) it automatically runs SpamSieve upon arrival of new mail (as intended). Now the weird thing is, a second passes after SpamSieve is launched and Mail.app also launches automatically. This is really annoying and I tried reinstalling the SpamSieve and going through all configuration options, but I couldn’t see what is wrong and what is triggering Mail.app to run.

If anyone else is experiencing similar issue, please share your experiences. Your suggestions are very welcome to eliminate this annoying issue.

Thanks

This is new in SpamSieve 2.9.33, which launches Mail in order to make sure the rules are in the proper state, if you had previously used Mail with SpamSieve. You can tell SpamSieve that you no longer want to use it with Apple Mail by uninstalling the Mail plug-in.

I use MailMate as my main software and Mail.app is also configured on a different account. Actually when I open MailMate I have no intention of running Mail.app automatically and vice versa. Is there any way to disable this behavior?

p.s. This is just happening on one of my machines. There is another machine using the same setup (Mailmate, Mail.app and SpamSieve) on which I am not observing this behavior.

Yes, you can disable it by clicking this link to set an esoteric preference. However, this means that SpamSieve will no longer disable its Mail rule if it detects that its Mail plug-in is not loaded. So if the Mail plug-in becomes disabled (e.g. as a result of updating it) and you don’t enable it, the Mail rule will move every message to the Spam mailbox without consulting SpamSieve. So just be aware that you are disabling this safety feature.