C-Command Software Forum

"Mark As Junk" doesn't MOVE email in Postbox on Yosemite?

Hi there,

I’ve been testing a few different email clients to use as a drone for multiple mail accounts under OSX Yosemite 10.10.1. My results so far:

  1. **Mac Mail **crashes randomly every few days, automatically downloads attachments and so is sadly no longer a candidate.

  2. **Airmail **has a great interface and tight SpamSieve integration, BUT has problems: can’t shut down gracefully (spinning beachball of death every time) and it randomly marks some mail as spam but leaves it in the Inbox. In the client it shows it moved into the spam folder (but greyed out / no right-click options available), but via webmail or other clients the mail is still in the Inbox. Shame - their support doesn’t seem to acknowledge the various users with the same problem.

  3. **Postbox **doesn’t seem to have these problems - so far has been reliable, however the “Mark > As Junk” command only *flags *emails and leaves them in the Inbox, it doesn’t MOVE them to the designated Spam folder. Is this by design? Or is there a fix for this?

Many thanks!

CR

It’s not by design. On my Mac with 10.10, Postbox does move the messages when marking them as junk. Please make sure that you have followed Step 7 of the instructions for every account.

There are also a number of other good mail programs that work with SpamSieve.

Thanks Michael, appreciate your reply :slight_smile:

I found a setting that appears to be off by default - Preferences > Privacy > Junk: “When I mark messages as junk > Move them to the accounts Junk folder” (is turned off by default, will experiment with this ON).

In your experience which is the most reliable client? The mailbox I’m monitoring is around 8gb in total and Postbox has now stopped filtering new mail after 4-5 hours of uptime. Restarting the client gets it working again, but I need to use the client as a drone for an iPhone user. Any advice welcome! :slight_smile:

Personally, I use Apple Mail, but I agree that the reliability has not been great, especially shortly after Mac OS X 10.9 and 10.10 came out. I suggest that you try MailMate.

Spamsieve not moving junk to junk folder in Postbox
I’m using SpamSieve 2.9.19 and Postbox 3.0.11 on a Macintosh 2.66 GHz Quad-Core Intel Xeon, 8 GB 1066 MHz DDR3, OS X 10.10.2. When I click “j” to mark a message as spam, the message disappears from my inbox, then immediately reappears. The junk message is not moved to Spam. Same problem as #3 below. I HAVE followed ALL steps in the SpamSieve manual for setting up Postbox, AND I’ve used the Postbox/SpamSieve combination on many different Macs and many different OSs. This is the first time a problem like this has occurred.

Help!

Postbox itself is what handles moving the message, so please report this to Postbox support. I would also suggest checking the Console for error messages.