Marking messages Good or Spam does not seem to have much effect

A couple of months ago you diagnosed my setup (somehow Junk filtering was NOT turned off). I followed your instructions; thanks for the followup.

These days I am continually marking and re-marking messages from the same sender Good, but they still end up in the Junk folder. The addresses seem to be in the whitelist, but that does not seem to have much effect. Some days the message is in the Junk folder, another day it is not.

I think I still have something not setup to get the best results from SpamSieve.

macOS Ventura 13.4.1(c), Mail 16.0, SpamSieve 2.9.52

-Bill Anderson

Please see this page. Most likely, the good messages are being moved to Junk by a server junk filter, not SpamSieve, and so you should turn off that filter or configure SpamSieve to rescue the good messages out of Junk.

Thanks, Michael. I did find that d*$m setting and unchecked it. Things seem better, but it seems like I will need to keep training the messages to get the Good messages recognized as Good. Does that sound right?

  • Bill A

No, it sounds like there may be something else going on. Please use the Save Diagnostic Report command in the Help menu and send me the report file, as described here.

Michael, diagnostic report attached

SpamSieve Diagnostic Report.tbz

Thanks for the report. Which setting did you change? It still looks like the good messages are being moved to Junk by a server filter or perhaps by another Mac.

Michael, thanks for the note. the setting I unchecked yesterday is this one:

That controls the Apple client junk filter. The server junk filter is configured separately.

Michael, thank you for this last message; very helpful.

Regarding server-side filtering. one server i use has an on/off switch for SpamAssassin, but no way to supress the ‘SPAM’ addition to the subject line.
from your documentation, it is a good idea to turn that off. Am I right?

  • Bill

Yes. I would think that if you turn off SpamAssassin entirely it would also stop adding the subject tags. However, if all you can do is turn off moving the messages that’s also OK.