C-Command Software Forum

Messages in Entourage marked as spam, but left in inbox

SpamSieve was working great with Entourage (and Tiger). It moved the junk messages into the Junk (Spamsieve) folder on my Computer. This week, however, it stopped moving them. They appear in my Inbox with a junk label and color, but aren’t moved. I reset spamsieve scripts, but it still the same. even running the script manually doesn’t move the message into the spamsieve folder. The spamsieve ‘moveifspam’ script moves it into a junk email folder.
Any ideas what could have changed? They were doing some work on the Exchange Server this past weekend, but I don’t know why that would affect this.
-wayne

I moved this question to a new thread because it doesn’t seem to be related to the Train as Spam command.

Which version of Entourage are you using?

To me, “running the script manually” means choosing “SpamSieve - Move If Spam” from the menu, and you said that works, so I don’t understand what you’re saying doesn’t work. It’s also not clear to me what you mean by “spamsieve folder” and “junk email folder”. There should be a single folder in Entourage called “Junk E-mail”.

Please make sure that you have two SpamSieve rules as shown here. They should be at the top of the list, with “SpamSieve - Move If Spam” first. Do you have any rules in Entourage’s Mailing List Manager window?

I’m running Entourage 11.3.3

Actually i also noticed that the former place where Spamsieve put the junk mail, the <Junk (spamsierve)> folder on My Computer, has a fixed number of messages, and when i identify a new message as junk, it goes now to a Junk E-mail folder on the Exchange server. I’ve posted a screen shot of the folders available.

Actually the MoveifSpam script doesn’t move the spam. Only identifying the message as junk moves it.

The rules look almost the same. ONly difference is the <do not apply other rules…> box is checked on both of my rules.

It must be something simple, since it was working so well for a while.

Unless you tell SpamSieve otherwise, you need to name your spam folder “Junk E-mail”, and it needs to be in My Computer. You should never identify messages as Junk or Not Junk in Entourage. Instead, use the SpamSieve training commands.

That’s expected, due to limitations of Entourage’s AppleScript interface and Exchange support. The proper way to manually apply SpamSieve is to choose Apply Rule ‣ All Rules from Entourage’s Message menu.

There are two differences, both of which will cause problems.

  1. Your “SpamSieve - Move If Spam” rule needs to have “Do not apply other rules…” unchecked.
  2. Your “SpamSieve - Move Messages” rule should be set to move Junk messages, not Important messages.

If you make it look “almost the same,” it may work, or work in some cases, or not work at all. If you follow the manual to the letter, you won’t have any problems.

entourage and spamsieve
ah, yes, almost is not good enough. I don’t know how this happened, but I’ll keep a better eye on who’s using this computer. But thanks so much for the clarification and assistance!
-wayne