C-Command Software Forum

Messages marked as Spam keep reappearing

Using Apple Mail 13.0. Have the plugin installed. Using it for a gmail account and also an Outlook Live account. I see Messages in the tool bar and have marked many messages as good or spam as appropriate and they disappear from the incoming or the junk box. The next day I see some of these message whether spam or not being delivered back into the junk email folder. The ones marked good are still in junk and not sent out to the inbox. I am new here and running the free version currently in hopes of making a purchase if I can get it to operate properly. Using MacOs 10.15.3

What am I missing.

Thanks for the assistance!

With the normal setup, the messages caught by SpamSieve will go to the Spam mailbox. If it makes a mistake, you should use the SpamSieve - Train as Good or SpamSieve - Train as Spam command. The former will immediately whitelist the sender, so no future messages should go to the Spam mailbox.

If you are getting good messages in the Junk mailbox rather than the Spam mailbox, that is probably due to a server junk filter. I recommend turning that off, if possible.

Hi Michael…
I have turned off the server filter but I must have something missing. I still get the spam showing in my junk mail box and things that I have marked as good still end up there too. I also still have most of the mail that I have marked as junk coming back into junk mail. I apparently have Apple mail set correctly because I can see the messages screen and choose all the options that are in it. I am using two accounts in Apple Mail. One is gmail and the other is Outlook live.

Thank you for your assistance with getting this issue straightened out.

Is this happening for the Gmail account or the Outlook one or both? How did you turn off the server filter?

The problem seems to be mostly with the Outlook email.
I turned off the Junk Email using the method that you show in your directions.

Gmail shows very little junk.

Do you mean these directions? If you’d like to e-mail some screenshots showing how you configured the server, I could take a look.

Another option is that you could set up this script to have SpamSieve rescue the good messages from the Junk mailbox.

Thanks for sending the screenshots. Those all show the configuration in Apple Mail. To configure the Outlook server junk filter, you would need to use your web browser to log into your account, as described here.

Hi Michael:

Things are much better with that change. I do have a couple emails that end up in Junk even though I keep marking them as good. A few spams a;so slip in even though I mark them as spam. I am open to your ideas as to how I can tighten up and avoid these issues.

Thanks ever so much!

Did you turn off the Gmail spam filter, too? If you send in a diagnostic report, I can take a look at what happened with the messages you trained and whether the problem is related to SpamSieve.

Hi again Michael{

I have turned off the Gmail spam filter and set everything as you have requested. Find attached is the SpamSieve file you have requested.

Thanks you again.

SpamSieve Diagnostic Report.tbz

Thank for the report.

It looks like nearly all the messages that you trained as spam were ones that Mail had not asked SpamSieve to look at. This could be because they had already been marked as read or moved out of the inbox before your Mac saw them.

You have the Spam-catching strategy preference set to be very aggressive, which is partly why you are getting good messages in the Spam mailbox. And some it looks like were caught as spam because you had trained previous messages from the sender as spam. Some of the good messages were not moved there by SpamSieve, though. Perhaps this was already addressed by turning off the Gmail spam filter.

Hi once again Michael:

I still have all spam that I have deleted coming back and the good mail comes back into junk. Perhaps, and I know you can answer this question I’m sure, it is I use apple mail for both gmail and Hotmail. My gmail feeds into apple mail. I do not go to a web
browser to view it. I also do this with my Hotmail (outlook) account as that is how I view it normally but am using apple mail to view it now. If I look at it without outlook I do not get a Messages notification in the tool bar overhead as I do in Apple mail.
Should I be getting the messages toolbar when using outlook via Firefox web browser or should apple just take care of the whole thing???

Thanks once more

Do you mean that you delete a message and it doesn’t say in the trash? Or that after training a message as spam you get new messages that look similar to the trained one?

If you have the SpamSieve rule set to move messages to the Spam mailbox, and messages going to Junk are not related to SpamSieve. It should be possible to turn off the server junk filters, as previously discussed. But if that for some reason doesn’t work, you could set up SpamSieve to rescue good messages from the Junk mailbox.

That’s perfectly normal and shouldn’t cause any problems.

I’m not exactly sure what you are referring to. Do you mean the red number in Apple Mail’s Dock icon? Firefox will not show any notifications for new messages. I recommend doing it all with Apple Mail.

Greetings Michael:

  1. After I mark an email as spam it gets deleted but the next time it is sent it doesn’t go to spam it goes back into my junk box.

  2. I get notices that I want to look at that come into my junk and I mark them as good but every day they go into junk.

  3. Server junk filters were turned off as you told me to last week.

  4. If I look at my outlook account via the web I do not see the “messages” toolbar that shows up with Apple Mail. I guess what I am saying is that looking at email via Firefox for instance does not allow me to mark any messages as good or spam. I can only
    do this when in the app. I guess this is by design, correct??

Thank you for your assistance again. I hope to get it right soon.

That doesn’t indicate a problem with SpamSieve. Server filters move messages to Junk before they get to your Mac, so SpamSieve doesn’t process those messages. Since messages in the Junk mailbox aren’t SpamSieve mistakes, I don’t recommend training them.

For the same reason, these messages weren’t moved by SpamSieve, either. To prevent good messages from going to Junk, you should turn off your server junk filter or configure SpamSieve to rescue good messages that were caught by the server filter.

Either the server filters are not actually off, or you have an additional rule in Mail (or on a different computer) that’s moving the messages to Junk.

Aha, it sounds like you are referring to the Message menu in Apple Mail. Yes, with the normal setup you would need to train from Apple Mail rather than a webmail. If you need to train from webmail you could configure SpamSieve for remote training.

Lastly, I see that you have SpamSieve set to move trained messages to the Spam mailbox under On My Mac but automatically caught spam to the Spam mailbox in your Hotmail account. You may prefer to adjust the SpamSieve rule to move the messages to the On My Mac Spam mailbox so that it’s clear which messages were caught by SpamSieve rather than the server.