C-Command Software Forum

Messages moved to Spam but not colored (Yosemite 10.10.3)

The incoming spams are moved to the Spam folder but color didn’t change as I have set up in the Apple Mail rules.

After upgrading to Yosemite 10.10.3, this is what I did:

  1. Started Mail w/o SpamSieve installed, need to see if I can get and send email first.
    (My user data is on a different drive from the OS and Applications.)

  2. Copied these into my new user Library:
    /Users/<username>/Library/Application Support/SpamSieve/
    /Users/<username>/Library/Preferences/com.c-command.SpamSieve.plist

  3. Installed SpamSieve

  4. Opened Mail to check, then exit to Install Apple Mail Plug-in.

  5. Opened again, and found SpamSieve installed.

  6. Delete Junk folder and uncheck Junk folder in Mail Preference

  7. Set up Rules with SpamSieve [Score] and then colors.

The spam seem to be getting into the Spam box under “On my mac” but none was colored as it did when I was running Snow Leopard.

Also according to the log, I don’t see the scores any more…

Please help! SpamSieve had worked well for me before this…

I suggest that you start out with the basic setup to make sure you can get that working first.

Do you mean that there are no “Predicted” entries in SpamSieve’s log?

Embarrassing typo in Apple Mail Rules
Michael,

Thank you so much for answering so quickly.

I found a type in the name of the top rule (SpamSieve [Score]) now it’s working like it always had. (I love it, btw)

In the process of finding the error, I noticed that the “SpamSieve - Change Settings” don’t seem to show up anymore. All I see is the “Message” in the top menu was highlighted in blue for a while and nothing happened after that.

I don’t think I need it anymore… if it is important, please advise.

Otherwise, thank you!

It’s not important. However, if that command doesn’t work, it could indicate problems with other commands as well. Please see this page.

Thanks for sending the log. It looks like SpamSieve isn’t fully working because of a file permissions problem. Your home folder seems to be on an external drive, so Get Info on that drive and make sure that “Ignore ownership on this volume” is unchecked.

Works after unchecked the “Ignore ownership on this volume”
I unchecked the “Ignore ownership on this volume” where my user directory lives and now SpamSieve is functioning again.

Thanks for helping me cross one more thing off of my OS upgrade list!