C-Command Software Forum

MobileMe junk folder

Since I trialled the MobileMe Mail beta, Mail.app has a new Junk folder (since it now lists my MobileMe account as a new mailbox at the bottom of the left hand column, with its subfolders including Junk). This matters because it is collecting individual junk messages and flagging them up on the Mail.app dock icon badge (I insist on having folders other than Inbox flagged up, but there is no way to specify WHICH folders other than Inbox). In order to disable this behaviour I have abandoned the Mail beta, which allows me to go into prefs and turn of MobileMe junk filtering. However it is STILL there and still adding new junk messages!

According to Mail Help if this happens I simply turn on Junk mail filtering in Mail.app - and lo and behold, it works. But of course I need to leave it switched off in order for SpamSieve to work. Any ideas how to lose the MobileMe account from the side panel in Mail.app?

If you turn off MobileMe’s junk filter in Safari, it should stop putting messages in the MobileMe Junk mailbox. Are you saying that this preference doesn’t work for you?

Mail always shows active accounts in the source list. You could uncheck “Enable this account” in Mail’s Accounts Preferences, but then you would not have access to that account’s messages. Perhaps I don’t understand what you’re trying to do…

I think it is a problem with MobileMe Mail Beta

There is no option to deactivate the Junk filter in Mobileme Mail Beta

I submitted it as a bug to Mobileme Mail beta

it is irrevelent to the setup on my Desktop (computer) Mail.app

Yes, and it seems that once you have been on the beta, you can’t switch off junk filtering even in the standard version, that is to say disabling it in prefs has no effect!

For sure. I had junk filtering switched off anyway since SS needs it so, and lo and behold using the MobileMe mail beta switched it on in such a way that I cannot now switch it off even though I am no longer on the beta!

I dont want to disable this account. It is my email account!!!

That’s what I thought, but you did say that you wanted to “lose the MobileMe account.” Anyway, it sounds as though there’s no way to turn off MobileMe’s junk filter due to a problem with the beta.

One option would be to turn on the junk mail filter in the desktop Mail, but to set it so that it doesn’t apply to any messages. For example, set it to “Perform custom actions.” Then set the conditions to “Message is addressed to my Full Name,” “Message is not addressed to my Full Name,” and “If all of the following conditions are met.”

Interesting workaround. I’ll give it a go and post back.

I meant that I wanted to lose the additional mailbox in Mail.app named after my MM account that appeared for the first time when I joined the beta. All mail should go into my main Inbox.

I too have MobileMe but have never tried the beta – and yet mysteriously I now have a ‘Junk’ folder in Mail.app at the bottom of my mailbox list. My SpamSieve ‘Spam’ folder continues to accumulate mail as before, but this new ‘Junk’ folder is also accumulating mail.

I logged into MobileMe via Safari and found the exact same situation. What’s strange is that the online MobileMe ‘Junk’ folder not enabled in preferences, and the Mail.app ‘Junk’ folder is not enabled in preferences – as I would expect since I have never had either of them enabled.

I can’t remember when I first noticed this new ‘Junk’ folder, but it wasn’t that long ago. So I’m wondering if it has something to do with the latest version of SpamSieve and/or something that has changed at the MobileMe end of things? But as I said, I’ve never used the MobileMe beta.

Anybody have any ideas?

SpamSieve will not use a mailbox called Junk unless you choose it in the SpamSieve rule in Mail’s preferences or using the “SpamSieve - Change Settings” command.

Thanks Michael! The finger now points to MobileMe…

Looks like some others have discovered this problem at the Apple Forums.

Edit: Today I logged into MobileMe via Safari to discover the new design is out of beta and online. I looked at the Mail preferences again, only this time discovered that the Junk Mail filter is no longer an option. This probably explains why it was filtering messages before, even though I did not have Junk Mail enabled in MobileMe preferences.

So apparently the MobileMe Junk Mail filter is now permanently on, and the user no longer has the option to turn it off. As a consequence MobileMe will be filtering messages before they arrive at Mail/SpamSieve, and I will need to check both the Spam and Junk folders. Too bad.

As I suggested, file a bug report to Apple

it is indeed a Mobileme problem
it should be an option on Webbased Mobileme

Michael - your workaround is ingenious but ineffective. Adding both rules ‘Message is addressed to my full name’ AND ‘Message is NOT addressed to my full name’ inexplicably does not prevent the Mail.app from capturing messages and marking them unread in the (now invisible) MM junk folder. I even tried adding the further action of marking any message that got through as READ, and even this does not prevent it from capturing messages and showing them as unread. This is crazy. Bug report to Apple!

Your first message said that you wanted to be able to turn on Mail’s junk mail filter due to the Dock icon badge functionality. When desktop Mail’s filter is on, it treats the server-side Junk mailbox differently. But, you said, “of course I need to leave it switched off in order for SpamSieve to work.”

The goal of my suggested workaround was to enable you to turn on Mail’s junk mail filter without having it catch any messages or affect SpamSieve. To my knowledge, it does this, and desktop Mail does not move any messages to the Junk mailbox. Of course, this has no effect on the messages that MobileMe’s filter has already moved to the Junk mailbox. That issue is out of our control, as far as I know.

Another partial workaround: you can set SpamSieve to put its spam messages into MobileMe’s Junk mailbox. This won’t prevent MobileMe from catching good messages and putting them into Junk, but at least then you won’t have to check two separate spam mailboxes.

Secondly, I filed a bug with Apple about the inability to turn off MobileMe’s junk mail filter, and they replied that it was a known issue that they are tracking under Bug ID# 7697915. So anyone interested in seeing this fixed might want to file a bug and reference that number.

Lastly, if e-mail is very important to you, I think the best solution is to get your own domain name. DreamHost and Pair are some inexpensive hosts that I’ve used and recommend. Other popular ones are 1&1 and GoDaddy. This gives you more control over what the mail server does—you can turn its junk filter off completely, if you want. Also, if you’re ever unhappy, you own the domain, so you can change to a different hosting company without changing your e-mail address.

Hello,
That’s a good workaround

but still Mobileme needs to be fixed; a bug was file on my behalf also (as stated before)

Thanks Michael

As I said in a previous message, it is a good trick
but when I end up with a spam message that wasn’t filtered as spam
and do a “Train as Spam”
it creates a Spam folder and puts it there instead of the Junk folder identified in the Rule (SpamSieve Rule)

any work around for this ?

Yes, you can use the “SpamSieve - Change Settings” command to control which mailbox trained spam messages to go.

Thanks,
I had forgotten about this;

Your prompt answers are always appreciated

Have a good day