C-Command Software Forum

Mojave Mail Menu Items Grayed Out After Installing SpamSieve Plug-In

I just upgraded to Mojave from Sierra. After the upgrade Mail would launch, open the menu bar with almost all options grayed out, and just sit. No windows, no options, no preferences.

After poking around and progressively moving prefs and account storage from the user Library I discovered that if the Bundles folder and the PersistenceInfo.plist from the Mail directory were removed, Mail would launch correctly.

I went through the SpamSieve install instructions, downloaded the latest version and made sure that the SpamSieve had full disk access before I tried to install the Apple Mail plugin.

As soon as the plugin is installed, the Mail app breaks again. Same issues.

Suggestions Michael? It’s only happened on this one machine. Another had no problems after Mojave upgrade from High Sierra.

I doubt this is related to PersistenceInfo.plist. You can probably just remove the Bundles folder or ask SpamSieve to uninstall its plug-in.

I don’t think it’s actually caused by the plug-in code, because if you haven’t enabled the plug-in yet (because you couldn’t get to the Preferences window), it’s not actually loaded. Something is going wrong in Mail itself as it prepares to load the plug-in.

I had one other customer who ran into this when Mojave first came out, and Apple advised him to erase the Mac, reinstall a fresh copy of Mojave, and then restore his user files from backup. That worked. So that’s an option, albeit a time consuming one.

It’s possible that something’s wrong with Mail’s files, which I might be able to figure out from a diagnostic report.

It also might help to reset or delete Mail’s DataVaults, (C.) and (D.) on this page.

Hi Michael,

You’re right. It’s the Bundles folder. I reset the DataVaults and the problem repeated itself. Let me know where to send a diagnostic report if you’d like.

Might have to do a clean install, which makes me oh so happy.

Another option: Since I have a another MPBP of similar vintage (a little later, a little bigger) could I sudo cp the Mail app from it onto a flash drive and drop it onto this machine? If it might not be the app itself, what other bits should I grab from either Library?

If it comes down to a clean install I might as well try some other hacks first.

Please send it to spamsieve@c-command.com.

I think the problem is likely not the app, but rather a data file that is messed up and should be deleted. So it’s probably not a matter of anything that needs to be copied. Did you try the more involved step of deleting the DataVaults folder? That would be easier than a clean install.

Thanks for sending the diagnostic report.

I’m not sure whether this is related to the problem, but it looks like your Mail files have some incorrect quarantine attributes. You can delete them by giving the Terminal app Full Disk Access and then entering this command in Terminal:

xattr -dr com.apple.quarantine ~/Library/Mail

followed by the Return key. I think it might be related because Mail seems to be encountering an error writing to your quarantine database:

2019-12-06 08:51:16.125813-0500 0xc496     Error       0x0                 
    959    0    Mail: (libsqlite3.dylib)
    [com.apple.libsqlite3:logging-persist] cannot open file at line 42270
    of [95fbac39ba]
2019-12-06 08:51:16.125817-0500 0xc496     Error       0x0                 
    959    0    Mail: (libsqlite3.dylib)
    [com.apple.libsqlite3:logging-persist] os_unix.c:42270: (1)
    open(/Users/kev/Library/Preferences/com.apple.LaunchServices.
    QuarantineEventsV2) - Operation not permitted

That did it! Thanks Michael!