C-Command Software Forum

Monterey (12.2) rejects SpamSieve 2.9.48

I’ve just migrated my data from TM backup to a new computer, after the drive failed on the old one. I’ve upgraded from Catalina to Monterey in one hit.

Setting up Mail is proving a challenge. It involves installing SpamSieve and MailSuite. The latter has gone ok. But Mail keeps rejecting SpamSieve. Here’s how the dance goes:

  • launch Mail
  • go to settings / General / Manage plugins
  • MailSuite is checked and SpamSieve isn’t
  • check SpamSieve and tap button to relaunch Mail
  • shortly after Mail quits I get this window:
  • Mail then relaunches and pops up a dialogue saying the MailTags are out of sync with the messages
  • Mail proceeds to reindex tags
  • then Mail opens as it should

Thereafter on every relaunch of Mail (with or without attempting to enable SpamSieve), all of the above steps will play out all over again. And so on ad infinitum.

I’ve checked ~/Library/Mail/Bundles. It contains MailSuite only. But SpamSieve still appears (unchecked) in Mail’s ‘Manage Plug-ins’.

Where to now?

But P.S. … SpamSieve is still interacting with Mail. I’ve just had this window pop up (also a repeat from earlier cycles):

It sounds like Mail’s private plug-ins folder got messed up during the migration. Please see this page.

Hi Michael,

Many thanks. That’s a start. Not a solution though. Might send a direct email for support. Briefly here: I deleted the folder (called “Bundles” rather than “Plug-ins” - a change made by Apple at some point, I assume?). But still had the same behaviour (among many weird stuff happening). In the process of fighting with it the “Bundles” folder mysteriously reappeared. And round we go …

Hi Michael,

Still not really right here. I’ve again deleted the “Bundles” folder (and disabled SIP just to be sure). Mail is now humming nicely, but with NO plugins anywhere. Open “Manage Plug-ins” and I have a blank space. (Prior to deleting the folder the panel showed MailSuite (checked) and SpamSieve (unchecked), and the folder showed MailSuite and nothing else).

I could have another go at reinstalling MailSuite and SpamSieve. But I very much expect I’ll be back to where I’ve been repeated times before, with MailSuite humming and SpamSieve being disabled my Mail :person_shrugging:.


Further update: I’ve now successfully reinstalled MailSuite. No more indexing issues. “Bundles” folder is back. Again it contains MailSuite but not SpamSieve. And as soon as I enabled MailSuite in “Manage Plug-ins” I again got the original message a la the image at the top of the thread.

Might be worth mentioning that the fix for the indexing issues with MailTags turned out to be related to a wider system issue. That was all fixed by re- signing in to my Apple ID in Sys Prefs / Apple ID. (It hasn’t fixed this present issue though).

Deleting Bundles won’t help. The folder really is called Plug-ins on Monterey. It’s located at /Users/<username>/Library/Application Support/Mail/Plug-ins/.

Thanks. Well alas. That hasn’t helped either. I did overlook the “Application Support” step, so I was looking in ~/Library/Mail. I’m now in the right folder, and have successfully deleted “Plug-ins”. But the results are no different.

(Mind you I am still having wider system issues, for which I have an open support ticket with AppleCare. So this might well be all part of that).

Yeah, it may be part of that and you could just try again after getting the other issues resolved. Or, if you want me to take a closer look now, you could:

  1. Choose Install Apple Mail Plug-In.
  2. Try enabling the plug-in in Mail.
  3. Right after that fails, use the Save Diagnostic Report command in the Help menu and send me the report file, as described here.

Three emails now sent. Two auto-generated error reports and one diagnostic report (after an earlier crash trying to create it :joy:). Ended up using a Dropbox link. Hope that worked. (Dropbox is struggling too).

Thanks for all this information. It looks like there are a variety of file permissions problems within your user account. I think these explain why you are getting errors (there was no crash) when installing the plug-in and also when saving the diagnostic report.

First, I recommend that you grant Full Disk Access to the Terminal app. Then you could try entering these commands in the Terminal app:

sudo chmod -RN ~/Library/LaunchAgents
sudo chmod -RN ~/Library/Mail
sudo chmod -RN ~/Desktop
sudo chmod -RN ~/Library/Application\ Support/SpamSieve
sudo xattr -rd com.apple.quarantine ~/Library/Mail

If Mail still rejects the plug-in after that, please repeat the steps from the previous post.

Sorry it’s been a while. Been busy fighting other system issues. Anyway here’s the output from those operations in Terminal:

Last login: Sat Feb 19 17:55:49 on ttys000

You have mail.

Restored session: Sat 19 Feb 2022 17:58:29 AEDT

The default interactive shell is now zsh.

To update your account to use zsh, please run `chsh -s /bin/zsh`.

For more details, please visit https://support.apple.com/kb/HT208050.

Sophia:~ lance$ sudo chmod -RN ~/Library/LaunchAgents


Sophia:~ lance$ sudo chmod -RN ~/Library/Mail

Sophia:~ lance$ sudo chmod -RN ~/Desktop

Sophia:~ lance$ sudo chmod -RN ~/Library/Application\ Support/SpamSieve

Sophia:~ lance$ sudo xattr -rd com.apple.quarantine ~/Library/Mail

xattr: No such file: /Users/lance/Library/Mail/Mail Lost+Found/Bundles/Herald.mailbundle/Contents/Resources/HeraldAgent.app/Contents/Frameworks/Sparkle.framework/Versions/A/Resources/fr_CA.lproj

xattr: No such file: /Users/lance/Library/Mail/Mail Lost+Found/Bundles/Herald.mailbundle/Contents/Resources/HeraldAgent.app/Contents/Frameworks/Sparkle.framework/Versions/A/Resources/fr.lproj/fr.lproj

xattr: No such file: /Users/lance/Library/Mail/Mail Lost+Found/Bundles/Herald.mailbundle/Contents/Frameworks/Sparkle.framework/Versions/A/Resources/fr_CA.lproj

xattr: No such file: /Users/lance/Library/Mail/Mail Lost+Found/Bundles/Herald.mailbundle/Contents/Frameworks/Sparkle.framework/Versions/A/Resources/fr.lproj/fr.lproj

Sophia:~ lance$

Still rejected plugin after this. I’ll be back …

Oh P.S. I had to wait about a minute at least after the second and final (5th) commands. Only then did it return anything. Before that, just sat with insertion thingy at start of a blank line

Well behold, we seem to be back on track, after reinstalling the plugin. But then again, Mail is running horribly slowly, and there are still system / permissions issues to iron out with Apple. That being so, I’m not yet ready to believe this issue is at an end. I guess we’ll see … Thanks for everything anyway. Great support as usual.

If Mail is running slowly or getting stuck, recording some sample logs may help figure out why.

Well interestingly it’s now running quite smoothly. Possibly the slow running was just the early recovery :person_shrugging:

1 Like