C-Command Software Forum

Monterey without Segmented Disk Image Format

Is there a work around for this:

Apple has deprecated the segmented disk image format starting with macOS 12 Monterey.

DropDMG can still create segmented disk images on Monterey

Yes. I tested that but how can I join the segments and open the consolidated dmg?

I figured it out. Can join all segments with Convert Image/Archive and profile set to dmg no compression. I just tried it. I had already tried the Join command but its for another function.

Thanks for pointing the way.

You can just double-click the .dmg file to open the segmented disk image directly. You don’t have to join it first. If you do want to join it, that can be done using the Convert command; you can keep it compressed or encrypted if desired. The Join Files command is for joining a non-dmg file that has been split and just needs the pieces concatenated.

Michael

I had tried double clicking the .dmg file before using the Convert command and the segmented disk image did not open. I only received the following error message:

The disk image couldn’t be opened.
Failed to attach disk image, error code 109.

I am guessing this is due to Monterey?

I’m not sure what error 109 refers to. Some disk images are in an older format such that (whether or not they are segmented) they need to be converted (which updates them to a newer format) before macOS will mount them.