C-Command Software Forum

New plain text file double quote

Hi
I’m entering code into a new plain text file created within EagleFiler. When entering a double quotation mark in the EF editor bottom pane it creates a smart quote. I tried changing Textedit to ignoring smart quotes and TextEdit now enters plain double quotes correctly however EF is still entering smart quotes. I can get around this by entering Ctrl Shift " each time but this is cumbersome. Is there a setting somewhere in EF to ignore smart quotes?
Thanks
Allan

After reading the manual more thoroughly I found the answer was to go to the Edit -> Substitutions sub menu and turn off smart quotes. This sub menu was grayed out however when I was in the editing pane it came to life.
EF’s features are very impressive.

EF is impressive. :slight_smile:

I have that substitution disabled and I still get smart quotes in EF plain text files when I paste a block of text with quotes in it. I have to manually replace them in this case. Got excited when I saw your post.

As with TextEdit and other places in macOS, the substitution settings only apply to what you’re typing. If you want to process text that’s already been saved to a file, I wrote a little script.

Or, you may be able to find a service or LaunchBar script that operates on the selected text.

Cool. Thank you, Michael.