C-Command Software Forum

New user has Merge Inbox question

I’m new to EagleFiler, and am in the process of importing a bunch of colelcted emails. I’m using Entourage to import .rge archive files, and then using the EagleFiler F1 key to bring those emails into EagleFiler.

I have a few emailboxes with 30,000+ emails, so on those I’m selecting about 5,000 at a time before I hit the EagleFiler capture key (just to be safe). The import is happening as expected, and I’m ending up with multiple email boxes in EagleFiler as expected:

Sent
Sent-1
Sent-2
Sent-3

My next step is to try to Merge the inboxes into a single emailbox called “Sent”.

The problem I’m seeing is this - when I select two of these items, lets say Sent and Sent-1, and then select the “Merge” command, I end up with Sent and Sent 1 in the Trash, and no Sent mailbox in the Records category still. However, it seems like it IS still there, because if I drag Sent and Sent 1 BACK from the Trash to the Records area, it renames them Sent-1 and Sent-2.

Hope this makes sense. I’m very confused at this point. Any help would be appreciated.

I’m not seeing this problem on my Mac; I end up with a single Sent mailbox in the same folder as the originals. Have you tried merging all four Sent mailboxes at once? What happens if you merge other mailboxes (not Sent)?

I think I may see part of the problem. I imported 12 sections from a single large folder, which should have created “Sent” through “Sent-11”. As I outlined above, I can see “Sent-2” through “Sent-11” only in EagleFiler. However, if I click on one of the mailboxes I can see and right click and select “Reveal in Finder”, I can see the files for “Sent” and “Sent-1” in that folder - they just aren’t showing up in the list under “Records” in EagleFiler.

Any idea why?

No idea, unless some sort of error or crash occurred. If you could send me the file:

/Users/<username>/Library/Logs/EagleFiler/EagleFiler.log

perhaps that will help me figure out what’s happening.

Meanwhile, how about doing a basic test of creating a new library, importing two mailboxes into it, and merging them? That will make it easier to see what’s going on without debris from previous imports and merges.

Secondly, 5,000 messages isn’t that many. Have you tried importing more at once?

Log file attached. I’ll try the test you suggest.

Thanks - I’m very impressed with your responsiveness.

Just did the test you recommended, and it worked fine. I’ll create a new Library and reimport the original items. How many emails should I feel comfortable importing at once? Is 35,000 doable?

Thanks. It looks as though one of the merges did not create a new mailbox file because it would have been identical to one that was already in the library. Also, one of the mailboxes (Sent Items-1) apparently was not in the expected format, so EagleFiler did not recognize it as a mailbox and instead imported it as a text file. This would explain why you didn’t see it in the source list at the left of the window.

That would definitely work with Apple Mail. I don’t have an Entourage database that large, but I would expect it to work provided that Entourage recycles its memory properly. Basically, I’m just saying that you might as well try larger batches and possibly save yourself some time merging.

Just imported another 15,000 email archive - worked perfectly. I’m going to move forward and assume the previous issue was a corner case.

Thanks for your help.

Just did another import of 42,000 emails at once - worked just fine.