C-Command Software Forum

No Quick Look Thumbnail

Hi there,

the preview is eagle filer can fall back to QuickLook for unsupported format.
What i understand is that the plubic API used is the one for “QuickLook thumbnail” for rendering in Eaglefiler.
On the other hand, calling Quicklook from the finder (or eaglefiler document list) will give a more complete preview: “QuickLook Preview”.

Here’s my problem:
I’ve compiled a Quicklook plugin with both “Preview” and “thumbnail” implemented.
I was expecting to see the "thumbnail’ rendering in Eaglefiler, but a just see raw text (the format is a text-based format)

Can you explain what’s happening ?

Thank you
I love Eaglefiler.

That’s how it originally worked. Starting with Mac OS X 10.7 Lion, there is now public API to access the Quick Look Preview. So EagleFiler will use that unless you are on 10.6.

Secondly, if a file’s type is unknown, EagleFiler will try to guess whether it is a text file. This is because people commonly create text files with many different extensions. EagleFiler displays text files as editable text rather than using Quick Look. You can force EagleFiler to treat a file as opaque by entering a command like this in Terminal:

defaults write com.c-command.EagleFiler NonTextExtensions -array skp

(This is just an example; EagleFiler already knows that the .skp XML-based format for 3D models should be treated as non-text.)

That’s how it originally worked. Starting with Mac OS X 10.7 Lion, there is now public API to access the Quick Look Preview. So EagleFiler will use that unless you are on 10.6.

Awesome ! I’m on Mavericks.

defaults write com.c-command.EagleFiler NonTextExtensions -array skp

Great !!!
BUT… it doesn’t work !

Im’ typing “defaults write com.c-command.EagleFiler NonTextExtensions -array md”
to enable Markdown preview.
And it changes nothing, even after restart in EF

is that the right command ?
Thanx for your quick reply.

Eric

EagleFiler does not reinterpret files that have already been imported. So the change will only take effect for files imported after you enter that command. You can tell whether it has worked because the Markdown files will no longer have a Kind of “Text File”. It will instead say “Record” or have a description from whatever application is declaring the Markdown type.

I’m sorry but no… new imported files still have the “Text file” Kind.
Maybe the problem is here:

have a description from whatever application is declaring the Markdown type

The quicklook plugin does not come from an application. I added it myself in Library/Quicklook

you can download the plugin from here:

Thank you !

Capture d’écran 2014-10-09 à 11.09.24.jpg

Thanks for letting me know. It looks like there’s a bug in EagleFiler’s handling of NonTextExtensions. If you send me an e-mail I can let you know when it’s fixed.

That actually does define a new document type called “Markdown document.” In any case, NonTextExtensions should work whether or not you have an application or plug-in that declares the type. The only effect of having the type is that you’ll see “Markdown Document” instead of “File” in EagleFiler. Either way it should not say “Text File.”

Ok Michael,

Thank you for the support.
Any chance that the fix will be in the next release ?
When do you plan to release an update ?
I use EagleFiler everyday for work and love it. I used to keep my journals in rtf(d) but i’m more and more using ipynb (python notebook) and markdown files. It’ll be great to see them in EF.

Regards
Eric

Yes, I’ve already fixed it.

Probably within the next month or so.

Probably within the next month or so.

Thanx !