C-Command Software Forum

Not moving back to inbox

HI,

After selecting ‘train as good’. Mail is not being moved back to the inbox and not marked as unread.

The settings (spamsieve - change settings) are such that it should though. This is a fresh install after years of use without any problems.

Background:
Fresh install, no drones, apple mail, no bulk email,
i don’t care what inbox it goes back to as long as it does and is marked unread.
Spam is initially moved to “All Rubbish” and lands in the bin of the respective account,
no local bin
Sieve 2.9.43

cheers,
Agzer

In order for this to work, the name of the mailbox that the message is in when you train it needs to match the name set in Change Settings.

Could you explain what you mean by “initially”? Are you moving the same message twice?

With multiple accounts there are multiple trash/bin mailboxes, just as there are several inboxes under “All inboxes”. When you trash an email it gets moved to the bin of the respective account. MacOs combines all the bins from all accounts in “All Rubbish”. Nominating ‘all Rubbish’ in the SpamSieve rule automatically puts the message in its respective bin. Mac Mail is quite good at keeping the accounts separate yet providing an integrated interface.

Hence as soon as you choose to leave trash on the server in stead of a single local mailbox, it is scattered over the bins of the multiple mailboxes. ‘Change settings’ only allows to nominate one folder (which is ok if you use a single local trash).

So I suggest that by putting “All Rubbish” in the change settings thingy, SpamSieve should be able to find the selected/highlighted email in question in its account bin and move it to its respective inbox.
(All Rubbish is a name Mac Mail introduced, not me)

As it has worked for years, when training an email as ‘Good’ SpamSieve did not have any trouble moving it back to the inbox that it came from, the inbox linked to the account that the message was sent to. I expect it to find the highlighted email in its account bin and move it back to its account inbox.

I hope this helps

OK, if that’s what you’re doing then the messages are only being moved once, directly to the appropriate junk mailbox.

If you tell it not to use a local spam mailbox, it will find the mailbox with the specified name on the appropriate server.

You should put the name of the actual mailbox that the message is in. Normally this will be “Spam” or “Junk”. (Mail probably shows the account names under “All Rubbish,” but that’s just for display purposes. Those are not the actual names of the mailboxes.) If setting it to “Junk” doesn’t work, please click this link to enable some SpamSieve debug logging. After relaunching Mail and SpamSieve, try training one of those messages as good. Then send me a diagnostic report, and it should show why SpamSieve did or did not try to move the message.

Thanks for your help so far.

Where can I find the name of the “actual mailbox”? what if it is not a single mailbox as I have indicated in the previous?

These are the names that Mail presents
image

image

image

image

image

image

As you can see all different as some refer to the account names, others appear in the message header display and the there are the folders in the library that are named differently.

Then there is the rule that refers to “All Rubbish”. Picture in next reply as I am only allowed to post 6 pictures it says

In ‘Change Settings’ I tried “Deleted Messages” as that is the default. On train as spam this puts the message in the bin of the iCloud account, no matter what account it came from. On train as good it moves it back to the correct account inbox (this is progress as before nothing was moved at all!, the tinkering has apparently done something)

I also tried “Bin” but this creates a local folder named Bin and puts the message in there. Eventhough it was instructed not to use a local folder.

So when you say “put the name of the actual mailbox” please tell me which name is that? And what if different accounts name their mailboxes differently?

I have kept on trying some different names in ‘Change Settings’ but to no avail. Now I’m back to the default “Deleted Messages” and when I now train as spam the message simply disappears. Can’t find it anywhere anymore.

I’m running out of messages to try on!

If you enable the debug logging as I mentioned, it will be in the Console log and diagnostic report. This is what I recommend because it will also tell you what it’s doing (whether it thinks it’s supposed to move the message, where it’s moving it to, etc.).

You can also see in Preferences ‣ Accounts ‣ Mailbox Behaviors which actual mailbox is mapped to each special mailbox. Finally, there is a script here that will list all the mailbox names for each account.

The default is “Spam”.

It will only create local mailboxes. So if the name that you specify is available on the right server, it will use that mailbox. If not, it will look in all the other accounts. If none of them have the right mailbox, it will create a new local one.

In my version, the default and only mailbox mentioned is ‘Deleted Messages’.

I suggest we keep focussing on the problem at hand rather than trying to react to quotes. The software is clearly doing things that are not expected and not easily solved. I am trying to give you the best insight into what’s happening in the best English I have.

The console.log inside the diagnostic report tbz mentions several entries of currentMailboxName=Bin.
‘Inbox’, ‘Drafts’, ‘Archive’ and ‘Sent’ can also be found in this 21.8 MB document.

Maybe you can be more specific as to what exact string I’m looking for?

As said, Bin creates a local folder.

It is concerning that SpamSieve now seems to make messages disappear after I have put the change settings back to the default ‘Deleted Messages’

Again thanks for your help so far

Yes, it says that because the most common mailbox people want to change it to is the trash, but the default (what it shows in the text field at the bottom unless you change it) is Spam.

You can search for AppleMailScriptDebug. Some questions to move towards a solution:

  • Do you know what’s changed on your Mac or with your mail accounts since this was all working for years? Did you configure the Mail or SpamSieve settings differently?

  • What are the actual names of the trash mailboxes? Even thought you can only specify one name, it’s normally not a problem if they don’t match because SpamSieve has a list of built-in names for recognizing spam/junk/trash mailboxes. But maybe your accounts are using something not on that list.

  • What does the log say about SpamSieve deciding to move or not move the message?

You may want to enable the backup feature. There is a bug in recent versions of Mail where, for some users, moving a message between accounts can instead delete the message. It sounds like you may be running into that if your accounts have different names for the trash mailbox. For example, as mentioned above, if the message is in account A and you have it set to use a server mailbox called Deleted Messages that does not exist in account A, it will fall back on using a Deleted Messages that it finds in another account B. And so it will ask Mail to move the message cross-account and possibly hit the bug.

Possible workarounds:

  • Set it to move trained spam messages to a local mailbox or to a server mailbox that exists on all accounts with the same name.

  • Make trash mailboxes with the same name and use Mailbox Behaviors to tell Mail to use them.

Hi again,

The textfield at the bottom shows whatever I type in there. The only hint it gives is Deleted Messages

What changed is that I set up a new/old mac. And I want to stop using a local folder (which works well).

And yes, what ARE the actual names of the mailboxes used? And which one do you put in if the names are all different? No idea and apparently you don’t know either. I have iCloud, gmail and exchange. Should not be hard I would think.

once more thanks for your help but I think I haver pointed out some eratic and unexpected behaviour that you may want to look at a bit more indepth. I am looking forward to an improved version, for now it’s back to the local spam folder as that always worked well.

No need to reply anymore. Cheers. A

All I’m saying is that the default is Spam. That’s what it said before you changed it.

As I wrote above:

Normally, most or all of them would already be known to SpamSieve as built-in trash mailbox names. So you would put in the one that’s non-standard. Once you tell me what the names are I can advise you better. There may be something else going on here because you are using standard/popular mail providers, so I would have expected it to just work. That’s why I suggested seeing what the AppleMailScriptDebug debug log entries say.