C-Command Software Forum

Not spam when manual trained result in two messages

Hi (again),

I have - for me - a strange problem.

Each time a message is wrongly put in the spam folder, then when the message is manually trained as not spam the message pops correctly to the inbox, but! each time a second version or duplicate of the message is downloaded so I end up with two of same message.

I am using IMAP, MS Outlook 2011 14.3.9, SpamSieve 2.9.11, Late 2013 15" MBP and OS 10.9 (13A3017).

My folders under IMAP > Advanced is setup as per attached screenshot.

Suggestion/idea why this happens?

Aja, when I try as I have read here to select (chose) any folder besides those on server, then none other are shown, as see on the same screenshot.

Edited 01122013-11:19:
I disabled SpamSieve and enabled Outlook’s own spam filter, when a messaged wrongly was tagged as spam and I told the message was not spam it appeared in the inbox as expected, but without a duplicated message.

Thanks Steen

SpamSieve IMAP Folders 01.jpg

In which folder are you seeing the duplicate message?

It might be because you have not chosen a folder next to Trash, where it says “Move deleted message to this folder.”

In the future, could you post full-size screenshots so that the text is easier to read?

I think it’s normal that Outlook only lets you move deleted messes to a folder on the same server.

Sorry, a folder was and is selected, but to show what I see when I click “chose” it became unselected and I only posted one screen shot.
But my bad I should have posted two screen shots.
So for all four IMAP accounts it looks like the attached screenshot.

For the future I will post full-size

SpamSieve 02 sh.jpg

OK. In which folder are you seeing the duplicate messages?

I see the duplicated message in the inbox after having done a Train as Good to the not spam message in spam/junk-E-mail/junk folders (each of the four IMAP accounts got their own spam/junk folder), but is not spam/junk.
Then after the Train as Good to the message the message goes (as expected) back into the Inbox where shortly after a duplicate of same message pops up.

I have tried only having one IMAP account with same result and I have tried each of the accounts as well.

What I can see is that for any of the four account then shortly after the duplicate message is “downloaded” from the mail server.

Steen

Sounds like it could be either an Outlook or server issue. Have you tried rebuilding Outlook’s database?

I am using three different servers two public and two private, the attached screen shots show two of the four one public and one private.

I have rebuild the DB several times.

I had same issue on my old MBP as I now have on my new MBP (late 2013 model)

SpamSiev IMAP 01 sh.jpg

SpamSiev IMAP 02 sh.jpg

Right after I sent the response I had two mails in the spam folder that was not spam.

The attached screen shots shows:

  1. The two mails in the spam folder

  2. The inbox without the two"spam" messages

  3. The inbox after having used the Train as Good where there now are two duplicates of the not spam message

SpamSieve IMAP 03 sh.jpg

SpamSieve IMAP 04 sh.jpg

SpamSieve IMAP 05 sh.jpg

Do the spams usually go to the Spam folder under your Inbox? With the normal SpamSieve setup, I would expect the SpamSieve - Move Messages rule to put them in the top-level “Junk E-mail” folder.

I have followed to setup from the manual as the attached screenshot show.

Some ends up in the on “My Computer Junk E-mail” folder, but definitely not all.
I see spam in all IMAP accounts spam folders.
Outlooks own junk-E-mail is not enabled as attached screen shot shows.

SpamSieve 06 sh.jpg

SpamSieve 07 sh.jpg

SpamSieve is set to move messages to the local “Junk E-mail” folder. It sounds like that’s working properly.

Messages going to other folders are either being moved by other rules that you created in Outlook or by a junk filter on your mail server.

I have contacted my server provider, metanet in Zurich, to see what they say as they offer very limited configuration.
And I have on my client no other rules than the two from SpamSieve.

Hi again - sorry for delay for update.

Yes, one reason found.
My provider had updated the interface used to access the server.
And as default Spam was set to be moved to then spam folder on server.
I changed this and now spam detected as spam by SpamSieve ends up in the spam folder on my computer.
So far so good!

But! When a message arrives in the inbox which is spam and I tell SpamSieve that the message is spam then correctly and as expected the message is moved out from the inbox, but the message is not moved to the spam folder on my computer, but instead to the spam folder on the server and darn there the message is duplicated.

Why is the message not moved to the spam folder on my computer? That is what I would have expected - or am I wrong here?

BR// Steen

With Outlook, the “SpamSieve - Move Messages” rule moves spams to the folder that you selected in the rule. When you train a message as spam, SpamSieve moves it to the mailbox designated in Outlook as the junk mailbox for that account. This can be selected under Accounts > Advanced… > Folders, but I think it always has to be on the server (if you have an IMAP/Exchange account).

Got it and as far as I have worked it out then you are right in your assumption on how outlook handles IMAP folders.

Cheers and thanks - Steen