C-Command Software Forum

Not sure what I'm doing wrong

Every time I save a website, I’m getting this message:This Web archive could not be displayed; perhaps the file is damaged or missing.

What am I doing wrong?

How are you saving the Web site? This error typically means that a file or folder has been moved/deleted/renamed from outside of EagleFiler so that the file is no longer in the location where EagleFiler stored it. Have you verified your library?

I’m using the capture key.

Here’s a screenshot on what I’m getting:

And then you immediately try to view the new file and get an error? Or is something else happening in between?

Is this happening when you press the capture key, or when you choose Verify, or at some other time?

Have you looked in your library’s folder in Finder to see whether the expected files are there?

Is your EagleFiler library stored in iCloud Drive with Optimize Mac Storage turned on?

Does the same problem occur if you try to capture into a new, empty library?

The error message comes up when I restart EagleFiler or shut my MacBook down for the night. I looked in the files folder and there are multiple files for what I used the capture key for. Yes it is stored in iCloud Drive with optimize Mac storage turned on. Yes it does this when I try it in a new library.

After a fresh install it seems to be working. I’ll let you know. Thank you for your help.

It sounds like what’s happening is that your Mac’s storage is almost full, so it is offloading (evicting in iCloud parlance) some of the files to the cloud. Then when EagleFiler tries to read the file, it isn’t there (although Finder shows a placeholder for it). If you update to EagleFiler 1.9.4 (in public beta), that version will detect these evicted files and download them as needed instead of reporting them missing. Or, if you can free up enough space or turn off Optimize Mac Storage, you can prevent the files from being evicted in the first place.

EagleFiler 1.9.4 has now been released.