C-Command Software Forum

One, just one not being sent to Spam folder

I’m running Mac OS 10.10.2, SpamSieve 2.9.19, Apple Mail 8.2. I have just one email that is in my blacklist that is not being sent to the Spam folder. I’ve checked SS is set up properly. This entry in Contacts has two email addresses. It that the issue? It shouldn’t as the email that is not being sent to the Spam folder is the one on the blacklist.

If you are curious about what SpamSieve is doing and why, you should always look in the log to see what it says about the message in question.

As to your specific question, I’m having a hard time understanding what you are trying to do. It sounds like you have blocklisted someone that’s in your contacts. Why?

The address book always overrides the blocklist except for any addresses that you have excluded.

He’s in my Contacts because while he is annoying by forwarding me stupid spam, I don’t want to delete his contact info in case I need to contact him. Just imagine your sister sending you pictures of cats and poems about dogs that she finds on the web. You may wish to have those directed to the Spam folder automatically, yet there may be a need to email or call or send a letter to your sister, and that contact info should be in Contacts.

I’ve unchecked “Use Address Book” and I’ll whitelist emails that get tossed into Spam that I wish to see straight away. I’m not keen on adding his email to my Contact, nor am I willing to use Terminal to overwrite a default. I’ll never remember that I did it, nor will I want to spend the time to find out how to undo it if necessary.

Thanks for your help.

OK, I would say these are unwanted messages but not spam by the normal definition. I don’t think it makes sense to teach SpamSieve that they are spam. I would leave him in Contacts but create a rule in Mail above the SpamSieve rule that moves the messages to the Trash or Spam mailbox. Then these messages will bypass SpamSieve entirely.

Thank you, you’ve been very helpful and timely with your advice. It’s very much appreciated.