C-Command Software Forum

PDFs blank white outline then slow to view and difficult to navigate

macOS Sierra 10.12 (16A323)
EagleFiler 1.7.1
MacBook Air (early-2014) 1.7 GHz Intel Core i7, 8GB RAM

Hello all,

***The following with View -> PDF -> Single Page

Wondering if anyone is having issues with viewing and navigating PDF files? I have a Library with about 400 mixed files but have selected a folder with only 24 small (1-4 page, 35K-250K) PDF files. I am trying to view these in the Record Viewer but when I click on a file I just get a blank white outline of the document in the viewer. After 10-20 seconds, the first page will render, but if it is a multipage document then the additional pages do not become available to scroll at all (two finger with the trackpad). However, if I click on the first page in the viewer window then I can use the arrow keys to move up and down the document (pinch to zoom will work once I am on each page).

I am having a hard time quantifying the issue. If I hit the spacebar to get a document preview then the file is instantly rendered and all pages are scrollable even if the background document in the Record Viewer is still plain white outline.

***The following with View -> PDF -> Continuous Scrolling

Ok, just found the View -> PDF options. So when I switch to the continuous scrolling mode, the first page is often blank white outline but the following pages are instantly viewable … then after 10-20 seconds the first page appears. Just to make it more interesting, sometimes it is the second page that is blank white outline but the first page and then pages 3+ are viewable.


This is strange. I cannot seem to reproduce all of these issues. Once I have viewed and switched away from a file, sometimes it is instantly available when I switch back and sometimes it returns to a blank white outline.

Just tried with a much larger Library with larger and longer PDF files. The same issue except the pages that are available to view instantly are pixelated and unreadable for 5-10 seconds until the screen is rendered clear. Again this is only in the Record Viewer because if I use the document preview (spacebar) then all pages are instantly available, scrollable, zoomable, and clear.

Any comments or suggestions would be appreciated. Let me know if I can provide any additional information. Thanks

This sounds similar to some Sierra bugs that I have reported to Apple. There were a lot of changes to its PDF subsystem. If you want to send me a few of the smaller files, I can compare with what I’m seeing here and add to the bug reports.

Some of the bugs only apply to PDFView, which is used in EagleFiler’s main record viewer. Thus, you can work around them by using the Quick Look view (Spacebar) or by double-clicking to open in Preview.

Michael, thanks for the reply. I will use Quick Look view as a workaround until this gets sorted. Sending over a few smaller files for you to compare with what you are seeing.

Also just did a quick check on an open library and did not find any problems with viewing Web Archives (Safari), Word Docs, PowerPoint presentations, image files (.jpg, .tiff, .gif), or text files (.txt, .cpp, .mak) directly in the Record Viewer.

Thanks again

Thanks for sending the files. These are displaying normally for me with macOS 10.12 (16A323) on a 2012 MacBook Pro.

Ok thanks. I tried again to find a pattern here but haven’t had any luck. My test cases were 14 - one page PDFs and 32 - two page PDFs.

For the first case, I selected the last in the Record list and waited 2 seconds then used the up arrow to move to the next file. If the Record Viewer was blank then I counted it. First time through 7/14 were blank. Second time through 9/14 were blank.

For the second case, first time through 29/32 first pages were blank. Second time through 28/32 first pages were blank.

No correlation with file size. Some of the blank ones are 50K while some of the viewable ones are 1MB.

Randomly clicked and scrolled through some three and four page PDFs. Some pages are blurry and pixillated, some are clear, and some are blank. Sometimes the first page is fine but after scrolling to the last page and back to the first, the first is now blank … If I wait long enough then the blank page does render, but once I switch away and back it is likely to blank again.

I am in the process of setting up a new 2016 MacBook, so I will take a look on that machine once I get a Library up and running.

Also to clarify, opening a PDF in Preview works as expected and Quick Look within EagleFiler works great (other than the limitation of needing to resize and zoom the quick look window for each file), so this issue seems limited to PDFs in the Record Viewer pane.

If I see any difference with the 2016 MacBook then I will post an update, otherwise I’ll try again with future updates. Thanks again.

Thanks for the update. I’m not sure what else to suggest at this point, but please let me know how it goes with the new MacBook.

I am now seeing this with some of my own PDFs if I view enough of them in a single session.

One idea I had is that until Apple fixes PDFView, EagleFiler could give you the option to display PDFs using the Quick Look viewer within the main window.

Sounds like a good option. Is there any downside or possible confusion with this stop-gap if Quick Look viewer does not allow copy & paste or search or etc? I was going to ask if there was a way to make the Quick Look viewer settings sticky between sessions. The only downside to hitting the spacebar on a file is having to resize the window each time.

Yes, the downside is that the Quick Look PDF viewer has much more limited features.

Do you mean to remember whether the window is open and its size? Or other settings?

Took a while to get the MacBook setup, but I am seeing the same behavior with PDFs.

For the Quick Look PDF viewer, I was thinking about both the window size and relative zoom. If I select a PDF and press the space bar then I need to increase the size of the window and zoom the document to fit. If I use the arrow keys to select a different PDF while in Quick Look then the window size and zoom stay the same for the new document. But exiting Quick Look and engaging it again in the same session resets the window size and zoom level to defaults.

EagleFiler 1.7.2 adds DisplayPDFsWithQuickLook to the esoteric preferences.