C-Command Software Forum

Poor Audio with AirPods Pro

Hallo, I just upgraded from the original AirPods to the new Pros. Now I have Problem which I never had before with the old ones. The AirPods Pro connects always with poor audio, even if I select the “just audio option” within ToothFairy (which should optional for the Pros as the utilize aac). I always have to go the the Audio Systempanel and select the build in mic. How can I fix that?

macOS Catalina 10.15.5
ToothFairy 2.6.2 (Setapp)

Just to be clear, are you saying that you see “SCO” in the Bluetooth menu for your AirPods Pro? That is strange because my experience is that the AirPods Pro normally can use AAC on macOS 10.15 even when using the microphone.

If you have Improve sound quality by disabling audio input from device checked, it should already be selecting Internal Microphone for you. So I wonder if some other app is interfering. You could start your Mac in safe mode and try to connect with ToothFairy and see if you notice difference.

Another thing you could do is enter this Terminal command:

defaults write com.robinlu.mac.Tooth-Fairy LogAudioInput YES

to enable some extra debug logging. Then when you save a diagnostic report it will include some information about whether ToothFairy tried to change the audio input and whether that succeeded.

I will check this, if I have any time soon.
For now I figured out, that the Simulator (Xcode) is what seems to be what cause the interference. It seems to get better if i choose a different audio device within the simulator.