C-Command Software Forum

Pre-purchase question: Blue text around links

Imported notes, and when writing text around links, text turns blue and underlined:

Dec-31-2019%2008-59-17

Note: This doesn’t happen with new notes.

Result: Blue, Plain text, underlined.
Expected: Black, Plain text, no underline.

Thanks

Thanks for the report. I’m not seeing this issue on my Mac. Could you tell me:

  • Which versions of macOS and EagleFiler you’re using?
  • How are you importing the rich text file? How are you getting the cursor to the end of the linked text?
  • If you Control-click in the text, is Substitutions ‣ Smart Links checked? If so, does unchecking it help?

Higher quality image:
05%20AM

  • EagleFiler 1.8.11
  • OSX Catalina 10.15.3
  • How are you importing the rich text file?
  • Imported from Desktop Evernote (ENEX)
    Evernote OSX Version 7.14 (458244 Direct)
    Editor: 69.3.10951 (15add1e)

How are you getting the cursor to the end of the linked text?

  • I move the cursor with my keyboard. Same thing happens with a tablet (Wacom)
  • If you Control-click in the text, is Substitutions ‣ Smart Links checked? If so, does unchecking it help?
  • It was checked, unchecked it, but saw no change in behavior.

Thanks. I was able to reproduce the issue. The same thing happens if I open the RTF file in TextEdit, so I think this is just how the macOS text view works. When you put the insertion point in a range of text that has a style, it seems to assume that you want to continue with that style. Whereas, if you are typing the link yourself, it knows to turn off the style when you press the spacebar.

Two suggestions:

  • It’s hard when the only text in the document is linked. But if there is other text, or even a blank line, you should be able to move the insertion point in from the other side, and then it will bring the plain style with it instead of the link style.

  • You can use Format ‣ Font ‣ Copy/Paste Style to restore the desired formatting to text that inadvertently ends up blue.

1 Like

Thanks, opened it in TextEdit and saw the same.

Is there a remove format option?

EDIT: Nevermind, saw the Default Paragraph button, thanks!