C-Command Software Forum

Problem with "command-%" not clipping text from browser

Regarding the key combination “Command-%”, the user manual says: “Type this from another application to import the selected text or URL into EagleFiler”.

When I highlighted text in Omniweb, then typed those keys, DevonThink opened. (I downloaded the demo to compare it to EagleFiler, then bought EagleFiler). I trashed DevonThink, and now I get an error message: “The capture web archive service could not be used because the “thinkpro2” application could not be found.” Does anyone have any ideas on how to fix this?

The key combination seems to work in other apps.

Many thanks …

Do you have any DEVONthink service files in the folder:

/Users/<username>/Library/Services/

or:

/Library/Services/

?

You can also invoke the EagleFiler command from the Services menu, and perhaps you can see there what other service is using Command-%.

No, there are no DEVONthink service files in either location. And, as you stated, I can indeed invoke the EagleFiler command from the Services menu, not using the keyboard shortcut. In the Services dropdown menu, no other service indicates it is using the keyboard shortcut.

Any other ideas? And: thanks!

Have you tried restarting your Mac?

Nope; didn’t think of that. :slight_smile:

I did run Service Scrubber, and deleted a couple of items that shouldn’t have affected the problem. But now the feature seems to be working.

I two more related questions. In Preferences, I have “Web page format” as “Rich Text”. I’ve only used the feature a couple of times, but one time it saved the highlighted information as a web archive, and the next time it saved it only as text. What’s the explanation for that?

Also: when I import the text, should the Info pane come up (it isn’t)?

Thanks, Michael. I’m very impressed with the program!

The Web page format preference controls what happens when you import an entire Web page (e.g. a URL). When using Command-% to import selected text from a Web view, EagleFiler always uses the Web archive format, unless you change the ImportTextAsWebArchive esoteric preference.

The Info inspector does not come and go automatically. If you want to see it, choose “Show Info” from the menu or click the toolbar button.