Problem with Quicklook Preview and QLMarkdown

I was hoping to preview Markdown files in EagleFiler. Following the advice in [Feature] Markdown support - #3 by tigertass I installed the QLMarkdown Quick Look extension and ran the following:

defaults write com.c-command.EagleFiler TextFileTypesForQuickLook -array md ics

I rebuilt my library and imported some new .md files. Now, when selecting a Markdown file I see a blank preview window with what looks to be a loading “spinner”. I’ve tried the recommended fixes in the QLMarkdown instructions but no luck. Hitting spacebar in EagleFiler shows the same spinner in the Quick Look window. On the other hand, selecting the same file in Finder and using Quick Look does show the Markdown preview.

One observation: Should I see EagleFiler in the Quick Look list in System Settings?

In the meantime, I’ve deleted the TextFileTypesForQuickLook setting and I’m back to seeing raw markup in EagleFiler but the Quick Look window triggered from EF is still empty.

macOS 13.1 and EagleFiler 1.9.9 (and also tried 1.9.10b1)

It’s not necessary to rebuild the library, since this setting only affects how text files are displayed, not what type of file EagleFiler considers them to be.

I’m not sure what’s going wrong there, as I just tested this with QLMarkdown 1.0.15 and it worked. Which version do you have?


It seems like the system is trying to use a custom Quick Look plug-in because you are getting the spinner rather than the default text view. I wonder if there’s a file permissions issue that is preventing QLMarkdown from accessing the file that you’re trying to preview. Which folder is it located in? Do you see anything interesting in Console if you search for the name of the file and then try to preview it?

I’m running 1.0.15 also. I’ve tried both the downloadable release and using homebrew’s Cask version.

That’s a good thought. I have tried libraries stored both on my Desktop and in ~/Documents. Just in case, I gave both EF and QLMarkdown “Full Disk Access” and confirmed that the actual file permissions are normal (644).

One thing that puzzles me is that QLMarkdown seems to work as expected when previewing from Finder (or Forklift), just not from within EagleFiler. I don’t know enough about how Quick Look works to be useful. I see nothing relevant in Console.

I appreciate you taking a look at it, thanks.

Yes, that is puzzling because from EagleFiler’s point of view QuickLook is just a black box. We ask the system to display the file using QuickLook but don’t have any detailed control over the process.

Does EagleFiler’s Quick Look window work for you with other types of files?

Are there perhaps any symlinks in the path to the file that you’re trying to preview?

Is it stored in iCloud Drive?

Yes, Quick Look works with every other type of file I’ve tried.

There are no symlinks that I’m aware of.

The library I was using was stored on my Desktop, which I have set to sync with iCloud. I created a new library right in my home directory and that made no difference in this behavior.

I’ll keep tinkering with it. It sure seems like something specific to my setup, but I’ll let you know if I learn anything.


It sounds like some sort of interaction between your setup and QLMarkdown specifically. So if you don’t find anything else yourself, perhaps they would be able to suggest what to look for.

1 Like