C-Command Software Forum

Problem with SpamSieve and Airmail on Mac

Hi there,

since yesterday morning (10th november) SpamSieve doesn’t work anymore in Airmail.

I didn’t change any settings, it actually stopped putting the mail in the Spam folder.
I’ve already done suggested troubleshooting (MacOs Privacy Setting, turn off and on in the Airmail preferences, etc.) but nothing changed.
The Log seems dead…

Any suggestion?

I’m on Mojave 10.14.6 and Airmail 3.6.73

Thank you very much in advance

If you are not seeing any new entries in the log, that means that Airmail is not sending the messages to SpamSieve for analysis (rather than that SpamSieve is thinking that the spam messages are good). Are you able to use the SpamSieve training commands from Airmail? Please tell me what happens and save a diagnostic report right after doing that.

Hi Michael!

Although the options under Download tabs in Airmail weren’t checked, I tried the steps you suggested me. Unfortunately the result is always the same. The log seems still dead…
You cab find the report attached…

Thank you very much in advance.

Valerio

Hi Michael, I tried replying 2 days ago but maybe I made sopmething wrong… Anyway, yes, I’m able to train spamsieve and if I do it the spam mail goes into the spam folder… But if the same mail arrives again, it doesn’t go automatically in the spam folder (as it used to) and in the log there 's no tracks of movements.

You can find the diagnostic report attached to this message!

Many thanks in advance

Sorry for the delayed reply. Just to confirm, you are using the “SpamSieve - Train as Spam” command, not “Mark as Spam,” right? The reason I ask is that, as you say, the log is showing no messages trained (or classified) since November 10. So from SpamSieve’s point of view, Airmail hasn’t been asking it to do anything.

Looking at the diagnostic report, I don’t see any errors reported from Airmail itself. There are a bunch of system errors like:

SpamSieve: (AE) [com.apple.appleevents:main] Since sending application [sess=100009 pid=8858 uid:501,501,501 g:20,20 pV:21360] is not permitted to send this AppleEvent to this process, returning an errAEEventNotPermitted reply.

This seems to indicate that Airmail doesn’t have permission to control SpamSieve. I know you said that you already checked this in System Preferences, but perhaps it would help to reset the privacy database as described in Troubleshooting Automation Access.