C-Command Software Forum

Ram Usage - Creeps WAY Up

Couldn’t find any other post on this, so…I wonder.

Only checked this 3-4 times, a couple in Demo and a couple after I bought license and, even though I haven’t had much time to use EagleFiler, therefore not much data added, the ram usage always seems to creep up to be extremely high, the longer I leave it open.

Generally using about 37 MB on opening, then after remaining open for a couple of days, I’m using around 400 MB - real ram, as indicated by Activity Monitor. This is the latest observation, with just one database created and containing just 2 light web archives.

iMac G5, 2G Ram

Thanks for the report. I’ll investigate this to see if there’s a memory leak. Does the Private Memory also increase? That’s the important number, I think.

Thanks for fast reply…
Don’t quite know how to tell Private Memory; as you know, Activity Monitor does not show that number, as I read it. I don’t have any utilities installed to maybe give more info on ram usage - never really needed one, I didn’t think

Only other app that creeps up really high, IMO, is Safari, even in its latest incarnation in 10.4.8.

I just added this forum post page to EF and ram usage actually went DOWN from 37 to 34…hmmm…

But, last night it had crept up to 387 MB after having been open for 2-3 days, not quite sure. And, nobody else seems to have mentioned it, so…

Appreciate your checking - may take some time, I’m guessing.

Thanks

You can show the Private Memory from the View > Columns menu. No one else has reported a memory leak, although that of course does not mean that there isn’t one. Since my last post, I’ve been running EagleFiler in Activity Monitor and the RAM usage hasn’t budged. I’ll try it again on a PowerPC Mac and leave it running overnight to see if anything happens. Did you have anything displayed in the viewer pane of EagleFiler’s browser window, e.g. a Web archive? It’s possible that there’s an animation or JavaScript that’s doing something while EagleFiler is otherwise idle.

Ahhhh…Private Memory - now I see it
Thanks for that tip - I haven’t modified my Views menu in a LONG time and didn’t even know that that was there.

So, like you, I’ve had EF open just a short time today and haven’t seen any memory creep at all yet today. I’m going to leave it open as long as I can and as soon as I see any significant movement upward, I’ll return and post again.

Also, I don’t believe that I had anything displayed when I was noticing the memory usage in Activity Monitor, but I’m not positive. Pretty sure, though.

Thanks, and “overnight” may not be long enough - I guess we’ll know tomorrow.

It’s been running since last night and the Private and Real RAM use still haven’t changed.

Same results here, Michael. Hope I didn’t report a non-issue.

I’m going to let everything run for several days and see if they reach the numbers I observed as I reported earlier.

Report on my ram usage
Report on my EF ram stats at this moment:

Real 112.95
Virtual 881.78
Private 101.47

Kim

This could be normal. EagleFiler will use more memory if you have more files and/or mail messages in the library, or if more than one library is open at once. The important question is whether the memory use keeps growing when you aren’t doing anything. I’ve not seen that happen myself; iknowmymeat says he saw it happen once but can’t seem to make it happen again.

Second day here and still NO CHANGE in ram usage - I can’t imagine what happened that I ever saw what I’m SURE I saw. Maybe I didn’t see it; however I still am pretty certain that I saw it on at least two occasions.

However, at this point, I’m beginning to feel that something was amiss on my end and until I see it again, I’m considering EagleFiler to not have ANY issue with ram usage.

Unless I notice a re-occurrence, I’ll only post here again after a few more days with a “final” follow-up.

I looked at this app a long time before buying as I already had a few other apps of a similar type and wasn’t sure that I wanted/needed another. However, in looking around for info re EagleFiler, I discovered quite a bit of info on its author/developer and found that he is quite active in a lot of areas and is highly respected in the Mac community.

All the info about Michael Tsai that I read more or less cinched my decision to purchase a license - I just knew that I was going to be buying something that was going to be a quality product. So, even if my “phantom” observation re this post turns out to be true, and that is doubtful at this point, I wasn’t concerned, as I am certain that any issues that appear will be addressed promptly and satisfactorily.

We haven’t found the precise cause of the problem yet, but it appears to be due to an interaction with Safari. After lots of surfing in Safari, both Safari and EagleFiler’s RAM usage grows, even if EagleFiler has been idle. Presumably this is a bug in Web Kit, but I’m still investigating.

Ram Usage Issue Resolved by Developer
About two revisions ago, mabe 3, EagleFiler ceased to seemingly “grab” more and more ram the longer it remained open.

I didn’t notice others chiming in with a similar issue here, so I wasn’t sure whether i was alone in this issue or not, so, when it disappeared, for me, i wasn’t sure whether a post here for final resolution would be relevant to anyone else or not.

Can’t hurt, though, I figure, so just for anyone’s benefit that might happen across this thread, I’ll just say that Michael looked into my reports to him and discovered the cause of whatever was occurring as I experienced it, and fixed it.

Knew he would - a key factor in my purchase of this great app!