C-Command Software Forum

Redirecting multiple POP/IMAP to central IMAP

Hi and hallo,

I have some problems execute rules in Entourage 2008 after setting up an IMAP account as a central account.

Let me explain the little bit complicated workaround:
Several POP and IMAP accounts are being used with their adresses. But for reasons of easy use and due limitations of some IMAP’s and due long time backing up a big Entourage database every day I want to use the biggest IMAP account in general,

  1. So at first all outgoing messages are move from local folder to the central IMAP sent folder. This works good.

  2. All incoming messages in local folder have to move to INBOX of central IMAP. Moving is OK. I’m using the move rule. But original messages stay in folder deleted as not read. Also all spam if I use SpamSieve rules.
    A short view of the rule show me that after moving no other rule is possible. But I want to delete original messages after moving to the central account. So this series of rules can’t work absolutely.

  3. At second SpamSieve’s two ways rule isn’t working on the central account absolutely too. Spam is marked as spam with the script but isn’t moved to the spam folder called “Junk-E-Mail” in german.

So my questions are:
Does there exist an opportunity to delete messages after moving to the central account? Or in a better way with deleting spam before moving?
And at second: Does anybody has an idea moving spam to the determinded folder at the IMAP account after marking as spam?

Thank you a lot in advance,

Kara

If you’re referring to POP messages, I don’t know why that would happen—on my Mac they’re deleted when a rule moves them to an IMAP server. If you’re referring to IMAP messages, Entourage has an option in the Accounts window where you can set what happens to IMAP messages that have been deleted. One choice is to leave them in place but mark them as deleted; another choice is to move them to the IMAP trash mailbox, which is what you want.

Have you selected that folder in the “SpamSieve - Move Messages” rule? Please make sure that the “SpamSieve - Move Messages” rule appears below the other SpamSieve rule and that you have only one Entourage category called “Junk”.

Dear Michael,

thank you a lot for your answer at first.

Thank goodness that you’re using an identical workflow. I know the mentioned option in Entourage. The problem referring at first to POP accounts. I have no idea why it is not possible to delete messages automatically after moving to IMAP. Every rule below the rule move all messages to dedicated IMAP taking no effect, because there is no option in first rule that allows another rule (box is grey).
So I think the problems is: The criterias after the first rule are identical to the first rule. And I can’t find another way that allows identical criterias.
But if I find another way I will give a shout.

Have you selected that folder in the “SpamSieve - Move Messages” rule? Please make sure that the “SpamSieve - Move Messages” rule appears below the other SpamSieve rule and that you have only one Entourage category called “Junk”.

I have done this exactely: Selected folder is Junk-E-Mail on the IMAP; it exists only one category Junk and it appears below Move if Spam rule. Do you have an idea of a variation of this rule for testing?
Note: All other rules below this two anti-spam rules for sorting mail into dedicated folders working fine.
It is possible that a rule “All messages” blocking other rules in the other e-mail protocol, i.e. POP blocks IMAP?

Best & thank you in advance

Kara

Me neither, since it’s always worked for me. Perhaps it would help to add an additional action to the rule that deletes the message, i.e. have Move and Delete actions on the same rule.

If you can’t get Entourage to do what you want, you could try configuring your POP server to forward the messages to the IMAP account’s address.

Please make sure that you have “Do not apply other rules…” unchecked for the “SpamSieve - Move If Spam” rule.

What happens if you select a message that’s been marked as Junk and choose Message > Apply Rule > SpamSieve - Move Messages?

I don’t think so, since Entourage has separate rule lists for POP and IMAP. You might want to check the Mailing List Manager rules, though.

Thank you a lot for this hint. It works for me!

This was my first idea to set up a variation. But unfortunately not all IP’s allow this.

I did unchecked “Do not apply…” at first as you described. This is absolutely OK. If I use the rule manually it is working fine! What I don’t understand why it isn’t working automatically. No other rule is above.

I agree, this is a logical argument.
Mailing List Manager is off. No rules are defined for this feature.
Maybe it is a special configuration of my provider. I have to research this. If I know a little bit more, I will write it down in this thread for the convenience of you and other users.

Many thanks for your help until this point!

Best
Kara

I don’t either. What happens if you manually change the category to not be Junk, then choose Message > Apply Rule > All Rules? This should mark it as junk again and then move it.

This is a very good idea, unfortunately I can’t check it out now because there is no new spam at this time.
But I have found another solution, maybe - it worked for the first tests: I changed the criterion “All messages” in the “SpamSieve - Move If Spam” rule to > folder > INBOX (IMAP) and the second rule is working successful now!

I don’t know what is happen because I’m not a technican nor a programmer. Is it possible, that the script recognize spam on one side but do not recognize the dedicated place (INBOX)?

I want to try out you recommended workflow above next and give a shout.

Best
Kara

That doesn’t really make sense, since “All messages” should include the inbox messages, but I’m glad it’s working for you.

The script doesn’t care about the location of the messages.

Thank you for this information
I agree with you, but could it be that this is a change in Entourage 2008? I’m going astray, but every time I’m setting up a new rule in Entourage 2008 -> IMAP the criterion “folder” ist shown and selected first now; this didn’t happen in Entourage 2004 I think. But I will going forward to look for another solution and as I said I will report this.

Best
Kara

Hello again,

as I promised I would give feedback for other solutions.

Instead what I have wrote above in this thread I can not recommend the workaround using a defined folder in SpamSieve - Move If Spam-rule NOW. All readers: Don’t use this!
My machine crashes all the time when I start Entourage with SpamSieve. And it crashed very deep, so it wasn’t be able to kill the process. Only if I launch Entourage seperately and then SpamSieve without start the script it worked.

So I looked for an alternative and I have found it:

Best solution is 1) to use 2 SpamSieve Rules and then 2) put it BELOW all other rules.

I don’t know why it didn’t work for the first time. But now it is OK, the script works fine on the IMAP.

Thank you all for your help again.

Best
Kara