C-Command Software Forum

Remote Training Script not working after 10.13 update

The remote training script (version 2017-07-18) was working fine before the update. After updating the script appears to run with out errors in the Script Editor but the Console is showing an error message “AppleEvents: received mach msg which wasn’t complex type as expected in getMemoryReference.”

TrainSpam is working from within the Mail application, I can “TrainSpam” from the inbox and the mail is moved to the local spam folder. When mail is moved to the TrainSpam folder from an iPad the mail is no longer being removed and processed as spam. (it was before the update to 10.13)

Any thoughts?

I also see that error on macOS 10.13. It seems to be due to an OS bug, but I’m not sure that it indicates a serious problem. When I run the script manually, it does train SpamSieve and move the messages out of the training mailboxes. Does this not happen for you?

When you are trying to run the script automatically, are you using an Apple Mail rule, or have you saved the script as a stay-open application? Have you tried enabling debug logging to see whether the script is actually being run?

The remote training script is not moving email on my system. It was running fine using an Apple mail rule before 10.13. I deleted the rule and rebuild the it and confirmed that the script was working, ran error free but still didn’t move the emails to the local Spam folder. After rebuilding the rule it is marking the email in the TrainSpam folder as Spam (grey color). Still doesn’t move it.

Please try enabling debug logging in the script and then run it from Script Editor. Do you then see any error messages in Console? What do the lines starting with “SpamSieve [Apple Mail Remote Training]” say?

Ran with debug on and saw that it was capturing and processing the emails correctly. Went back and deleted the TrainSpam rules for each email account and rebuilt the rules. Hit “apply” the rule. Now the spam filter is marking the emails in the TrainSpam folders as spam and moving them the the local spam folder on my Mac.

Not sure why this didn’t work the first time I rebuild the rules. I may have hit the “don’t apply” button instead of “apply”.

Still getting the “getmemoryreference” error but SpamSieve seems to be ignoring the error notification.

I’ll keep an eye on the issue and see if it comes back.

Thanks for the help.