C-Command Software Forum

RTF and RTFD

What is the difference between RTF and RTFD files? The RTF files that I imported into EF got imported correctly. I imported some RTFD files into EF and they imported as folders.

RTFD documents are stored as a folders (a.k.a. packages), since they may contain embedded graphics files in addition to RTF text content. There is a bug in the current version of EagleFiler such that if you import a folder containing document packages, the packages will be imported as folders rather than as documents. Importing packages by themselves will work, however.

Michael,

Thank you for clearifying that for me.

This is fixed in EagleFiler 1.1.2.

I just tried importing a .pkg file (instead of importing the .zip file where it was stored), and I got a folder named “-1”. Is this the expected behavior and related to this?

That’s not the expected behavior. The .pkg should be imported as a file if that’s how it’s treated in the Finder. It’s working correctly on my Mac. Could you tell me exactly how you imported it?

(Short story: import using F1 fails.)

Here is what I did exactly:

  • I chose a “.zip” file in my EF library, did a “reveal in Finder”
  • in Finder, I uncompressed it and got a .pkg file.
  • I dragged this file to my Desktop to get it out of the way
  • I went to my desktop, selected the file, and hit “F1”
  • I got a “-1” folder in my EF library

As you told me it’s working, I tried dropping it on the drop pad and this time it worked, so I guess it’s the F1 importing that does not know how to deal with it.

Thanks. I was able to duplicate the problem using the capture key. I’ll get this fixed soon.

This is fixed in EagleFiler 1.1.3.