C-Command Software Forum

RTF problems in Mojave dark mode

Hello Michael
Working with EF 1.8.4 and Mac OS 10.14 in dark mode I have the following problem:
When creating a new RTF file, always starts with white background and white text color (with the consequent annoyance)
I try to change the EF preferences for “Rich text font”, but the changes does not remain, every time I create a new RTF it returns to white color for text & background.
(Nothing of this happens when creating a RTF directly in TextEdit)

Do you think it’s a EF-bug or I’m doing something wrong?

PD: I’m love the EF dark mode: Great job!

This is working as designed. EagleFiler is following TextEdit’s lead by using black text on a white background, even in Dark Mode. This is because RTF files store color information, so they are supposed to look the same on any device. If you create a plain text file EagleFiler will switch the colors for you automatically.

I’m not sure what you mean here. The font settings in the preferences do not relate to colors. And RTF files created in TextEdit are also black-on-white.

EagleFiler does let you edit the text and background color from the Format ‣ Font ‣ Show Colors window. You could set up a document the way you want and then add it as stationery to make it easy to create more document with those colors.

Thanks for the answer and the suggestion of stationery workaround. But sorry, I think there is a missundertanding:

Here is my problem, in my case, in dark mode EF using white text on a white background (“White over white” is my problem)

At the moment I can solve it with your stationery suggestion, but I do not understand why happens this.

Many thanks

I’m sorry for misreading your original post. It think this is actually caused by a bug that I just fixed, and a public beta version with the fix should be available soon.

This is now fixed in EagleFiler 1.8.5b2.