C-Command Software Forum

Sent duplicates in inbox

Logically this is more likely to be a Gmail issue than a SpamSieve or Mail.app issue. But as the onset of this behaviour coincided with my new installation and setup of SpamSieve, and as I can’t find a solution through the Gmail forum, I’m hoping for some clues here …

Since setting up SpamSieve with my Mail.app, every message I send is instantly duplicated in my inbox as if I were a recipient. (And no, I didn’t Cc or Bcc to myself either.) I’ve noticed that all these messages have inter alia a header:

Return-Path <myusername@mydomain.com>
. I’ve tried creating this Mail rule to delete these dupes:

But that doesn’t stop it.

Any ideas?

This does seem like a Gmail issue (although not one that I’ve seen before). SpamSieve doesn’t see your outgoing messages, and neither do regular Mail rules, which is why yours doesn’t work.

It might help to temporarily make a new Sent mailbox and tell Mail to Mailbox > Use This Mailbox For > Sent.

Thanks Michael. Might try that. But I get the same behaviour with emails sent from my iPad. Does that suggest this wouldn’t help?

It suggests that you might need to fix the Sent mailbox in the iPad’s settings.

Well, some things are just too wonderful for me … No idea what happened under the hood in Gmail, but something I did has stopped this behaviour. AFAIK all I did was toggle a couple of filters, which I had created after studying this thread. Based on that I created one filter on “@” in ‘from’ and another on “@” in ‘to’.

Why that filter should have any connection with this behaviour defies me. But anyway, all I did was fiddle about with various combinations of deleting and recreating those filters. Several steps of said fiddling made no difference to the behaviour. But it finally stopped when I had the filter on “@” in ‘from’ without the equivalent on ‘to’.

That’s how it is now, and the behaviour’s stopped.

Or maybe not … :o

Looks like I spoke too soon. It’s advanced from always to intermittent … :frowning:

Mystery remains …