C-Command Software Forum

Shortcut key [cmd/%] imports inconsistent

I have ImportTextAsWebArchive set to import in RTF. A web page selection imported via the Import Services imports as a RTF. However, when using the shortcut key [cmd/%], it sometimes imports a selection as a WebArchive and other times as a RTF. I’m unable to see a pattern as to when this happens.

I always use the shortcut key first and if it imports as a WebArchive, I would then re-import the same selection using the Import Services menu which imports as a RTF everytime.

Any idea what could be causing this inconsistency?

I would expect those two methods to produce the same results, because EagleFiler itself doesn’t even know whether you used the menu command or the keyboard shortcut. It just sees that the service was invoked. Which application are you importing from? Are you changing the selection at all between using the keyboard and the menu? Are you using the contextual menu or the menu bar? Is there a particular Web page that exhibits the problem more reliably?

This happened when importing from Safari Version 5.0.3 (OS X 10.6.6). During times when importing via the keyboard shortcut imports as a WebArchive instead of RTF, I would then re-import the same selection of a page in Safari (without changing anything) using the Import Services menu. This method would import as RTF every single time.

I haven’t really been paying much attention to Web page particulars and will do so from now on to see if it will help pinpoint this inconsistency.

Did you ever try the keyboard shortcut a second time?

Nope and I will do this next time I come across a site that does not import as RTF and will also take notice of the site. Haven’t been able to get this to happen yet.

I see it happening with selected text from Safari’s Reader, not a web page. Sorry for originally mis-stating that it happened with a Safari web page.

Using the Import Services on the Reader page imports as a RTF, but the pressing the [cmd/%] shortcut keys imports it as a WebArchive. Is this the expected behavior? Tried this with several Macworld articles.

When you say “Using the Import Services,” what are you doing, exactly? I just tried it on this Macworld article. With the first paragraph selected, pressing Command-%, choosing “Services > EagleFiler: Import” from the contextual menu, and choosing “Safari > Services > EagleFiler: Import” from the menu bar all imported as RTF.

What I meant by “Using the Import Services” was – Safari>Services>EagleFiler: Import.

Guess I wasn’t clear when I was trying to say that I selected a Safari Reader page [View>Enter Reader] or [Shift-Cmd-R], not the actual web page. I tried the same page that you tried, but only converted it to a Safari Reader page before pressing [Shift-Cmd-%] to import it as a RTF, but the resultant was a WebArchive of the web page. However, using Safari>Services>EagleFiler: Import on this same Reader page imported it as a RTF.

I sometimes have difficulty expressing in English cuz American Sign Language is my primary language. Hope this is clear enough this time.

You were clear. I also went into Safari Reader before making the selection. So it seems that we are doing the same thing but seeing different results. I’m using Mac OS X 10.6.7 and Safari 5.0.5, whereas you said you had 10.6.6 and 5.0.3. So perhaps updating will help.