C-Command Software Forum

Should I exempt any mail from junk filtering?

I am using Apple Mail 10.4.10 and have the SpamSieve filter as the only active rule in my preferences. To take advantage of the option to automatically delete junk (spam) mail, I selected Enable Junk Mail filtering in the Junk Mail preferences, then I used the Advanced option in Perform Custom Actions to set up the two conflicting conditions IS in my Address Book and IS NOT in my Address Book. When I click on OK, the Junk Mail preferences change to Automatic and there is a box checked to exempt Mail addressed using my full name from junk mail filtering. Is that how the Junk Mail preferences should be set? The preferences change back to those settings as soon as I click OK in the previous window.

I also used the Message>SpamSieve-Change Settings to change the name of the spam mailbox to Junk and edited the SpamSieve rule to move all messages to the Junk Mailbox.

That’s probably OK, although I have not tested that particular setup. I know that using the Full Name conditions works, and in that case it doesn’t matter what the checkboxes say.

good mail ending up in Junk mailbox
The reason I asked this is because I’ve recently started having messages remain in the Junk mailbox that have always been moved correctly. I think I messed up and used Mail’s Mark as Junk a few times and now the junk mail filtering is conflicted. I tried reseting the junk mail database in Mail and that didn’t help. Now when I go to Advanced and try to set up the two conflicting rules, Mail won’t allow me to have IS in my Address Book and IS NOT in my Address Book. After doing one, the other is grayed out and can’t be selected. I’ve opened the SpamSieve log and it appears that SpamSieve filtered correctly, but the message stayed in Junk Mail. Here’s the log entry:

Predicted: Good (1)
Subject: RE: Thanks
From: kathmc@charter.net
Identifier: AxaOlQdWrARP22KZICmI2A==
Reason: ("kathmc@charter.net") matched rule <From (address) Is Equal to "kathmc@charter.net"> in SpamSieve whitelist
Date: 2008-01-03 22:23:18 -0600

For the other good message that was in Junk, there is no mention of it in the SpamSieve log. Both good messages remaining in Junk were colored white, by the way.

Can you help me figure out what’s going on? I’m using Mail 2.1.1 (752.3).

After writing this message and returning to Mail, both messages in the Junk mailbox were gone and have seemed to completely disappeared. I did a search in Mail and it didn’t find either of them.

“Remain,” meaning that you select a message, choose “SpamSieve - Train as Good,” and it doesn’t move?

Then you should find those messages and use “SpamSieve - Train as Spam” so that SpamSieve also knows that they’re spam.

How did you do that? There is no command in Mail to reset the junk database.

Please try using the Full Name conditions instead. If you cannot setup the conflicting conditions, you should disable Mail’s junk mail filter ASAP to prevent further problems.

This shows that SpamSieve examined the message when it arrived and thought it was good. If it went into the Junk mailbox, that was because Mail’s junk mail filter was not properly disabled.

Did you check all the inboxes? Do you have Mail set to auto-delete messages in the Junk mailbox?

“Remain,” meaning that you select a message, choose “SpamSieve - Train as Good,” and it doesn’t move?

No. If I understand the action of SpamSieve, all messages go first to the Junk mail folder, then are moved out to the inbox if they’re not spam. The problem messages are good messages, but weren’t moved to the Inbox and remained in Junk.

Then you should find those messages and use “SpamSieve - Train as Spam” so that SpamSieve also knows that they’re spam.

I have deleted all those messages, so I can’t do that now.

How did you do that? There is no command in Mail to reset the junk database.

In the Junk Mail Preferences, there is a button to the right of Advanced that says “Reset.” When you click on it, there is another pop-up window that asks for confirmation that you really want to reset the Junk Mail Database.

Please try using the Full Name conditions instead. If you cannot setup the conflicting conditions, you should disable Mail’s junk mail filter ASAP to prevent further problems.

I was able to use the Full Name conditions and set it up with those.

This shows that SpamSieve examined the message when it arrived and thought it was good. If it went into the Junk mailbox, that was because Mail’s junk mail filter was not properly disabled.

Maybe with the Full Name conditions selected, the junk mail filter will be disabled.

Do you have Mail set to auto-delete messages in the Junk mailbox?

No. It’s set to Never.

No, that’s not how it works. SpamSieve is just like any other Mail rule. Incoming messages go into the inbox, unless a rule specifically moves them elsewhere.

That’s too bad. If you notice accuracy problems with SpamSieve, you may need to reset the corpus and re-train it in order to correct this.

You’re right, of course. Sorry I got confused.

Yes. Let me know how it goes.