C-Command Software Forum

Slow import on Mountain Lion

After upgrading to Mountain Lion the import became really slow (mainly for PDFs). Anyone else having this problem?

Is there a way of logging the import process to see where’s the bottleneck?

Cheers,
–sergio

Please open the Activity Monitor program (in the Utilities folder in your Applications folder). Select EagleFiler in the list. When it is slow, choose Sample Process from the View menu. Then save the resulting data to a file and submit it via e-mail.

It looks like you’re running into an Apple events (AESendMessage) bug in Mac OS X 10.8.2. This is affecting dozens of applications. I will try to work around this in the next version of EagleFiler. But, for now, you can probably avoid the problem by logging out and logging back into your Mac or by entering this command in Terminal:

sudo killall -KILL appleeventsd

Another, permanent, workaround is to tell EagleFiler not to try to read or write Spotlight comments:

  1. Set the Spotlight comments preference to Ignore.
  2. Uncheck the Copy tags to Spotlight comments preference.
  3. And then click this link so that EagleFiler doesn’t try to copy the Spotlight comments when importing.

The bug seems to be fixed in Mac OS X 10.8.3.

And EagleFiler 1.6 adds a workaround so that there won’t be any problems if the bug in the OS comes back.