C-Command Software Forum

Snow Leopard rejects the SpamSieve plug-in

SpamSieve plug in is automatically turned off when I try to open Mail. If I force Quit and restart mail it will open. Then if I manually open SpamSieve it seems to work. I never had this problem with 10.5.8

I have not seen that problem myself or heard other reports of it. What does the error message say? Which version of SpamSieve are you using?

Please check the folders:

/Users/<username>/Library/Mail/Bundles
/Library/Mail/Bundles

Are there any .mailbundle files there besides SpamSieve?

I am using Vs 2.7.5 It said:

Incompatible Plug-ins Disabled
Mail has disabled the following plug-ins:

 SpamSieve

Contact the makers od these plug-ins for versions
that are compatible with Mail 4.0 and Message 4.0

What did you find in those folders? What happens if you launch Mail after choosing “Install Apple Mail Plug-In” from the SpamSieve menu?

I tried to reinstall the SpamSieve Plug-in from the SpamSieve menu with Mail closed. When I opened mail I got the same dialog box stating the incompatibility.

When I open /Users/<username>/Library/Mail/Bundles

I get Bundles/SpamSieve,mailbundle/contents/info.plist
MacOS/SpaimSieve
Resourses/all the language lproj’s

when I go to: /Library/Mail/Bundles I get
SpamSieve.mailbundle/contents/info.plist/MacOS/SpamSieve/Resources/

That sounds like the problem. There should be no SpamSieve.mailbundle in /Library/Mail/Bundles. I don’t even know how it got there, since SpamSieve doesn’t install it there.

OK, I moved SpamSieve.mailbundle to the desktop. When I started Mail it worked without the incompatible plug-in dialog box. Should I toss the one on the desktop? By the way, I did reinstall the plug-in for apple and it seems to be OK.

Yes, there should only be one SpamSieve plug-in, and it should be at:

/Users/<username>/Library/Mail/Bundles/SpamSieve.mailbundle

still rejected
hi michael,

i’ve got the same problem :
after installing the plug-in from spamsieve, and launching mail (4.0) i get the same error message, then the bundle gets moved to the disabled folder (except that a quirk of the french version of osx 10.6 creates a new disabled folder for each rejection…).

quitting both mail & spamsieve, then manually moving the plugin to the right folder results in the same cycle, and, obviously, spamsieve never gets launched (i see elsewhere on the forum that others have also complained about spamsieve not launching)

any clues? anything i can try to help you understand the problem??

(encl. 3 screen grabs)

Earlier in this thread, I suggested checking the /Library/Mail/Bundles folder and choosing “Install Apple Mail Plug-In” from the SpamSieve menu. Have you done this?

yes, i’ve re-installed the plug-in (NOT the app & all my many-years long prefs/lists etc) some 10-15 times, testing both with spamsieve launched and not launched before re-launching mail.

i’m a longtime ss user and have been updating the app regularly as you published excellent updates. it has always flawlessly updated an kept y mail free from spam, be it with mailsmith or mail (and maybe soon, when you get it off the ground, i’ll migrate definitely to postbox)

You said that you had the “same problem,” but there are still some things that are not clear to me:

  1. Do you have a second copy of the SpamSieve plug-in installed at:
    /Library/Mail/Bundles/SpamSieve.mailbundle
    (i.e. not in your home folder)?
  2. Does SpamSieve filter the messages if you manually launch it?

To me, those are the key characteristics of what Lmoran1 observed.

hi michael,

  1. no, i dont have much in the /library; just an empty “AccountTypes” folder
    (see the screen-grab)
    so maybe it’s not the exact same problem :frowning:

  2. i’ll need some time (monitoring mail’s activity & trying to launch ss manually) before i can answer your second point.

… i’ll let you know as soon as i try

hacky solution
(me again)

one can temporarily solve the problem by running mail in 32bit mode
(“Get Info” on Mail in the Finder, then check the “run in 32 bits” box)

doesn’t help michael solve the case, but will allow others to carry on…

That’s strange, because SpamSieve’s plug-in is a “fat binary” that supports both 32-bit and 64-bit execution. What happens if you type this command into Terminal:

file ~/Library/Mail/Bundles/SpamSieve.mailbundle/Contents/MacOS/SpamSieve

? I wonder if you have some other kind of plug-ins or haxies that are interfering. Everything definitely works if you install SpamSieve on a fresh 10.6 installation.

michael, terminal sez :
/Users/nader/Library/Mail/Bundles/SpamSieve.mailbundle/Contents/MacOS/SpamSieve: Mach-O bundle i386

It should also say “Mach-O 64-bit bundle x86_64”. So it seems as though something deleted the 64-bit part of your SpamSieve plug-in. You can get it back by downloading a fresh copy of SpamSieve and then asking it to install the plug-in.

michael,
done that, terminal now (correctly) lists 4 architectures, and mail works fine in 64bits and the plug-in.
so that might be a new answer to some of the problems on the forum!
(ie : dont use non-snow-leopard utilities to slim down apps; heck, in fact, with gigs of unused disk space, dont even bother)

thanks a lot for the time & guidance

I followed this thread because I was having the same problem.

When I typed the requested command in Terminal, it came back with only 3 architectures, but one of them was the x86_64 bundle.

Whenever I restart Mail, SpamSieve doesn’t open at the same time like it used to. Is that a new behavior?

Which problem is that? This thread is about Mail displaying a dialog that says the SpamSieve plug-in is incompatible. Your post in the other thread made it sound like you had a different problem.

That sounds good. With SpamSieve 2.7.7 there should be three architectures: x86_64, i386, and ppc7400. What kind of Mac do you have? Do you see the SpamSieve commands in Mail’s Message menu?

SpamSieve’s behavior with Mail has not changed. SpamSieve is only supposed to open when Mail receives new messages and applies the “SpamSieve” rule to them.