C-Command Software Forum

Some spam messages going to my Junk folder

I use Apple Mail and SpamSieve 2.9.28 on my mac under OS X 10.12.4 and my mail comes to me via gMail.

Some spam winds up in my Junk folder even though when I look in SpamSieve’s corpus, keywords in the subject line of the spam have a 100% probability of being spam. I checked SpamSieve’s setup instructions and my SpamSieve rule is positioned at the top of my rules and it is exactly like it should be. Enable junk mail filtering is also unchecked. When I see emails in my Junk mail that should be spam I “Train as Spam” them and then delete them.

Am I doing something wrong?

Yes, you should not train messages in the Junk mailbox as spam. They were not processed by SpamSieve because they were already caught by a server filter before they got to Mail. So SpamSieve did not examine them, and training it will not affect where they go. You could turn off the server filter or try one of these other options, depending on what you’re trying to accomplish.

“You could turn off the server filter”.

I use gMail and when I go to Settings->Filters and blocked addresses I don’t see anything there. In the Labels tab “Spam” is set to “hide”, and while [Gmail]/Spam/Spam99, etc. are set to “show”, and “Show in IMAP” is checked, those folders don’t show up in my Apple Mail (they did at one time).

I will try the “Turning Off the Gmail Spam Filter” and see what happens.

That seems to be working, thanks.

Great—thanks for the follow-up.

10x as many messages going to Junk Folder
Hi - I have had the same thing occurring and did not know it was a problem.

Every day, about 10-20 messages are in my Junk folder but only rarely do any messages appear in Spam.

I had no idea what this meant so I have been marking them all as Spam and deleting them.

I read the advice to “turn off the spam filter on the server.”

I use Apple Mail, Sierra as it comes with the OS.

Do you know how I may turn off the server spam filter on Apple Mail? I guess I thought those messages marked as Spam at the server would just never get to me.

Now that I know why this is doing this, I’d love to fix it.

Apple Mail’s client filter can be turned off as shown in Step 7. Server filters cannot be turned off from within Apple Mail. You generally need to log into the Web site for your mail provider. There are instructions for some common providers here.