C-Command Software Forum

Some uncolored spam in Junk; server junk filter & Apple Mail junk filter both off

Most of the spam in the Junk folder has been colored by SpamSieve. However there are a few spam messages with an uncolored background and brown text, so I assume SpamSieve hasn’t seen them. But I don’t know why.

Apple Mail gets its email from two Gmail accounts. Both Gmail accounts have been configured (per Help section 7.6.3) to “Never send it to spam”. Apple Mail has been configured as described in Help 3.1. macOS is v10.15.7.

Usually this means that a server junk filter moved them to Junk before they got to your Mac. Perhaps Gmail is not obeying your “Never send it to spam” for some reason. Or, do you have any other Macs or devices that might be moving the messages?

Is there a problem because some of these brown messages are actually good? Or are you just curious how they got there?

None of my other devices are moving messages. I believe the “Never send it to spam” filter I’ve set up in Gmail is not matching all the messages I’m getting. I’m not very familiar with the different search operators, but I’m wondering if the filter rule, “{(to:me) (deliveredto:USERNAME@gmail.com)}”, is too specific. A lot of the spam I get has variants of my actual USERNAME, which doesn’t match USERNAME@gmail.com but still gets delivered, bypasses the filter rule, and is processed (by Gmail) as spam.

It’s not a big problem, as long as the spam is ending up in the Spam mailbox, but I’d like all my incoming spam to be processed by SpamSieve.

In theory, the deliveredto is supposed to make it match all the messages received at that address, no matter how they were addressed.

You could try setting up SpamSieve to rescue good messages, and then it will process everything caught by Gmail, too.

I believe I’ve figured out the problem. I use a “dotted” string in the local part of my email address (like “STRING1.STRING2@gmail.com”). The filter I created in Gmail used this same string as the argument for deliveredto. The spam messages I get, however, use both the dotted version and the un-dotted version (“STRING1STRING2@gmail.com”). Although Gmail delivers both forms to my account–ignoring dots or their absence–the filter apparently does not and all the un-dotted messages were slipping through. I added an additional deliveredto term for the un-dotted form and now all the messages are kept out of Gmail Spam until SpamSieve processes them.

Glad you figured it out! I’ll update the documentation to make note of that.