C-Command Software Forum

Spam left in inbox

Spam is deleted but is also left in my inbox. I deleted SpamSieve and reinstalled but the problem continues. I have the spam deleted rather than moved (originally I was finding it in the spam account and in my inbox).

I have had this problem on my MacBook Pro with the current Big Sur since Big Sur was installed.

Please help. All this spam on my inbox is very annoying.

Are you using Apple Mail? If so, please make sure that you have configured the SpamSieve rule in Mail to move the messages to a mailbox on the server. Mail in Big Sur sometimes leaves copies of messages in the inbox if you have selected a local spam mailbox. If you want the messages to go to the trash, you can select a server Trash mailbox in the Mailbox Behaviors section of Mail’s Accounts preferences.

Thanks for responding.

I tried using the server spam mailbox, for me Gmail/Spam. It moves the spam to that mailbox but also in my inbox. Then I tried straight delete. Now the spam does not appear in the spam mailbox but is still remaining in my inbox. There must be some answer.

Do you have more than one mail account?

Yes I do but they are all gmail accounts (5) and one iCloud account. 99 per cent of the email is received by [one Gmail account].

You may be able to work around the problem by clicking the link in #5 on this page to not mark spam messages as junk. Otherwise, it’s important to follow the instructions in #4 to use a Spam mailbox that’s on the same server as the inbox. So, if you have multiple accounts, you might need a separate rule and mailbox for each account.

Thank you Michael. Hitting #5 seems to have solved the problem!

Jacquie

1 Like