Spam Sieve Rule disable on every restart in Apple Mail

Starting about a week ago, whenever I open Apple Mail after a boot-up, I get a SpamSieve dialog box that the add-in rule is disabled. When I check rules, it is indeed disabled. It runs fine after I re-enable it.

I think this may have started after the last Apple Rapid Response Security Update, about 1 week or so ago.

My set-up is:
M1 MacBook Air
MacOS 13.4 (22F66)-current public release
Apple Mail 16.0 (3731.600.7)-also current public release

Any suggestions on how to fix this?



This is probably happening because Mail is taking a long time to load the SpamSieve plug-in, so the app thinks that it hasn’t loaded. Is Mail taking a long time to launch at login? If so, you could follow the Slow Launching instructions to speed it up.

Thanks Michael,

Mail loads pretty quickly (it seems the same as before the problem), but I went ahead and tried the slow-load fixes in the link anyway; first the manual fix and then the automatic fix. Unfortunately, neither solved the problem.

Any other thoughts?


Does the problem only occur when you boot your Mac or any time you launch Mail?

Also, could you check that SpamSieve has Full Disk Access?

Voila! Full Disk Access had become disabled. Re-enabling it fixed the problem.

It was occurring every time I would open Mail from a Quit or Forced Quit status, as well as on boot-up.

Interestingly, for several days after the Apple Emergency Response Update, all of my FDA enabled apps became disabled and for several days in a row required re-enabling each time I booted-up. I must have missed SpamSieve.

Many thanks!