C-Command Software Forum

SpamSieve 2.9.4

The following was posted on the SpamSieve blog:

Version 2.9.4 of SpamSieve is now available. This is a free update that includes the following changes:

  • Made various changes to improve SpamSieve’s filtering accuracy.
  • Revised and expanded the Frequently Asked Questions to make it easier for people to find, fix, and report problems.
  • Fixed a problem where SpamSieve could crash when processing messages from Apple Mail on OS X 10.8, particularly after the Mac had awakened from sleep.
  • Worked around an issue on OS X 10.8 that could cause training SpamSieve from Apple Mail to be very slow.
  • The Train as Good
    command in Outlook will now move messages from the trash back to the inbox. - Made various updates to the manual for OS X 10.8 Mountain Lion, for example clarifying that SpamSieve works (via Apple Mail) during a Power Nap.
  • Worked around a problem where Apple Mail couldn’t communicate with SpamSieve if the /etc/hosts file was damaged.
  • Improved the error reporting when SpamSieve detects that one of its files is damaged.
  • Added defensive coding to try to track down a notification icon problem when running in French.
  • You can now set the MJTSoundLoadFromApps default to false if you want to prevent SpamSieve from looking for notification sounds installed by other applications, e.g. to prevent mounting an encrypted Microsoft User Data folder.
  • Fixed a bug handling errors if a software update failed; if it succeeded, the .dmg file is now deleted to reduce clutter.
  • After purchasing, SpamSieve used to show your user image to indicate that it had been successfully personalized. It now shows a generic checkmark to avoid prompting you for Contacts access on OS X 10.8.
  • Added an icon for the crash reporter, since it’s now displayed under OS X 10.8.
  • Fixed a bug where Apple Mail on Mac OS X 10.5 would log (harmless) errors about _NSAutoreleaseNoPool.
  • Fixed a bug where the Apple Mail plug-in sometimes logged confusing error messages about not being able to launch SpamSieve even though it was already launched.
  • Fixed a bug where the Apple Mail plug-in reported the wrong installation path in an error message when running on OS X 10.8.

SpamSieve 2.9.4 works with Mac OS X 10.4 through 10.8 and requires an e-mail client. Older versions are available for older operating systems. For information about previous releases of SpamSieve, please see the version history.