C-Command Software Forum

SpamSieve 2.9.42

Version 2.9.42 of SpamSieve is now available.

This is a free update that includes the following changes:

  • SpamSieve now runs natively on Apple Silicon Macs.
  • Worked around a macOS bug that could block communication between Apple Mail or Outlook and SpamSieve on Apple Silicon Macs. This could cause training not to work and/or messages to accumulate in the InboxSpamSieve folder.
  • SpamSieve now tries to detect if Apple Mail will incorrectly report an “Incompatible Plug-ins Disabled” error on macOS 11 (e.g. when the installed version of the plug-in actually is compatible) and explains how to fix this.
  • Improved the following sections of the manual:
  • SpamSieve now maintains its own error log files, so you can still access information for troubleshooting when the macOS system log isn’t working properly.
  • Improved the installer and diagnostic report to better work around problems with Apple Mail’s plug-ins folder on macOS 11.
  • The software updater reports a more useful error message if you try to update SpamSieve while running it from the disk image. This should prevent confusion where you continue running an old version despite telling it to update.
  • The Apple Mail - Move If Spam script now lets you set a server spam mailbox name via the user defaults without having to edit the script.

SpamSieve 2.9.42 works with macOS 10.9 through 11.1 and requires an e-mail client. Older SpamSieve versions are available for older versions of macOS. In-depth information about SpamSieve is available in the manual.