SpamSieve 3.0 not auto filtering

Please use the Save Diagnostic Report command in the Help menu and send me the report file, as described here.

Thanks for sending the report. I’m not sure what to make of your statement above, since the report does show 4 spam messages that were caught today. You can see which ones by looking at the bottom of the Log window for the ones that say Predicted: Spam. Were these messages colored as spam and/or moved to the Junk mailbox?

(There is one that was trained as spam very early in the morning, presumably before you selected the inboxes to filter, so that doesn’t seem relevant here.)

The report also shows no messages trained as spam today. So SpamSieve thinks it got everything right today. If that’s not the case, you should be correcting the mistakes. This helps improve the filtering accuracy and lets me see in the report what you wanted to have happen.


Thank you for the prompt reply.

From the LOG window here is an example of SpamSieve 3.0 NOT working:

I highlighted three emails - same SPAM emails from Amazon sent on 3 different days. SpamSieve 2.xx would have caught the first one (9/29), but SpamSieve 3.0 did not so I manually trained it as spam. Same email arrived in my INBOX the next day (9/30). I trained the second one as spam. The following day (10/1) same spam email arrived and I also trained it too as spam.

SpamSieve 3.0, at a minimum, should have flagged and removed the 9/30 and 10/1 emails from my INBOX, but it did not.

Those are all green; if you click on them it will say that they are not mistakes because SpamSieve had not made predictions for those messages. Mail hadn’t ask it to filter them. I think this is because you didn’t have Filter spam messages in other mailboxes enabled until 10/3. After that, the log indicates that SpamSieve is looking at and catching the spams.

I believe SpamSieve is working now that I have added the INBOXes as other mailboxes to filter. Thinking out loud… there does seem to be some lag time between when emails hit the inbox and when SpamSieve 3.0 processes them. For example, I was playing with the Green Flag option. Numerous emails came in and not one was flagged. Sat there for a few minutes staring at the inbox and then slowly email after email got flagged so I least know SpamSieve 3.0 is active.

You can watch the progress in the Settings window:

Next to the Filter Now button it will say which mailbox it’s processing, so you can see if there’s a particular one that’s slowing it down. Or, if it’s mostly idle, you could set it to check more often.


Yes, that worked. Much, much better now.

Think I was used to SpamSieve 2.0’s rule such that spam emails were automatically sent to the junk mailbox (never saw them in my inbox). Now with SpamSieve 3.0, everything hits the inbox and is then sorted.

Your help is much appreciated - thank you!

5 posts were split to a new topic: AppleScript Error With “Select Mailboxes to Filter…”

@Michael_Tsai I would suggest that both the documentation and the interface should lay more stress on the importance of checking “Filter spam in other mailboxes” and selecting your Inbox folder(s). Until I read through this thread and did that, SpamSieve was not filtering messages as they arrived and I had to select them and choose Filter Messages manually (I could not use the keyboard shortcut as it is not working globally, so I actually had to choose physically from the menu bar itself). But once I had set things up to filter the “other” mailboxes every 60 seconds, all was well. The notion of “other” here is thus wrong; the user needs this to be enabled for Inbox folder(s) in order to get SpamSieve to keep working at all over the course of time.

Yes, I have some changes in the works for the next version, and there have already been some updates to the online version of the documentation.

Please start a new thread about this or contact me offline so we can figure out what’s happening here.

My understanding of this issue is evolving. I never encountered this in the first two years of developing and testing the extension. Very few people seemed to encounter it during the beta period, and it seemed that reinstalling the app would get it working and then it would stay working. So I thought it was fine to leave the workaround under the feature for “other” mailboxes and mention it as a FAQ but not recommend that everyone set it up this way.

Now, Mail does not reliably communicate with the extension on any of my Macs, and I was able to reproduce the problem with a clean Sonoma installation and Apple’s own Mail extension sample code, and a lot of customers (but I still think a single digit percent) are encountering the issue, too. For some, it happens right from the start. For others, everything works fine for days/weeks, and then suddenly (without any software updates or even a restart) it stops, and so we have to break out the workaround.

So I now think that people should enable inbox filtering “just in case.” And I have accelerated plans to optimize the feature for very large mailboxes, since that’s less of a niche case, with more people using this feature and using it on core mailboxes, which tend to be larger.

1 Like

Sounds awesome, and let’s keep this in perspective: with the inbox filtering enabled, things are working great!

1 Like

It’d just like to let you know that auto filtering has been working reliably on my MacBook since I installed macOS 14.1 Public Beta 2. I didn’t do anything special, it just started filtering again.

I’ll update to Public Beta 3 today—let’s see how that goes…

Thanks for letting me know. I do find that reinstalling macOS or SpamSieve often helps, sometimes only temporarily. It really seems like there’s an OS (rather than Mail-specific) issue that’s preventing the communication between Mail and the extension, as if the PlugInKit registry is confused.

My SpamSieve was working fine. Then, without doing anything, it stopped working.

SpamSieve 3.0.1b2 can now automatically filter new messages in the inbox that Mail failed to send to the Mail extension. So, in most cases, you no longer need to do anything to work around this Mail bug.

If the green flags are being applied automatically, that implies that it did not stop filtering. You should check the Log window to see what it says about these messages and train them if they’re spam.

Updated to b2. Now SS is sending to the extension. Thank you.

Great, thanks for the follow-up!

To be clear, it’s probably still not using the extension, just automatically applying the workaround. You can see in the Info ‣ Origin section of the Log window how SpamSieve accessed the message. It will say whether it was from the plug-in, the extension, filtering other mailboxes, or (new) filtering the inboxes.

1 Like

I turned off “Filter spam messages in other mailboxes”, installed b2, and waited overnight for some spam to arrive. Sure enough, b2 is behaving as I believe we expect: in effect, it is doing by default what “Filter spam messages in other mailboxes” was doing — it is (periodically?) polling the inbox(es) after the fact to see whether there are messages that the extension mechanism did not report to it initially. So it’s basically the same workaround in another guise, as I understand it. Which is fine, since the workaround does work around the issue, and I think this is a better way to package the workaround. Nice!

Great, yes it polls using the same interval as Filter spam messages in other mailboxes.

Yes, just trying to make it friendlier by being opt-out instead of opt-in, by not requiring any configuration or updates if you change your accounts, and by trying to protect you from large inboxes that could make Mail hang. Post 3.0.1, I will look into making it faster and more efficient.

1 Like

With SpamSieve 3.0.2b1, I think this issue is now fully fixed. If you encounter the bug where Apple Mail stops sending new messages to SpamSieve’s Mail extension, SpamSieve will automatically filter the new messages in another way, and this should be fast and work with mailboxes of any size.