SpamSieve 3.0 on Apple Mail quit working

Note: why is inbox red in this screen?

It has to do with the text right below the mailbox list:

To avoid slowing down Mail, only select mailboxes that receive new messages. If there are lots of old messages, move them to an unfiltered mailbox.

The red is to alert you that these are large mailboxes that will take a long time to scan for new messages and that may slow down the responsiveness in Mail.

My SpamSieve has totally stopped filtering. What should I do?

[I am available on a zoom call. Perhaps you can get it started again.]

First, from the screenshot it looks like you have two mail accounts with the same name. This may prevent SpamSieve from filtering your other mailboxes. Can you rename one of the accounts in Mail’s settings?

Second, I still recommend that you move most of the messages in the red INBOX to another mailbox. Filtering will be much faster, and Mail will be much more responsive, if there are fewer messages for SpamSieve to check when it’s looking for new messages that need filtering.

All of my mail accounts have separate names.
I have deleted many of the emails from that inbox.
Spamsieve was working then stopped.
It is not about speed—Spam sieve was doing fine with this inbox.
Spam sieve has stopped (not a slow down issue).

I need help.

To clarify: Spamsieve has stopped on all inboxes (not just this one).

How about if I delete the rules left over from Spamsieve 2.0?

In the screenshot above, it looks like there are two called MIH. Could you check the Settings ‣ Accounts window in Mail? Maybe there is a disabled account at the bottom with the same name?

Please use the Save Diagnostic Report command in the Help menu and send me the report file, as described here.

Yes, you can do that.

I hope this helps


The account list looks good.

It looks like you need to check the box to enable Filter spam messages in other mailboxes and then click Select Mailboxes to Filter… and reselect your inboxes.

I changed the account name to MIH1. Here is the file to filter window:

Now MIH is distinct from MIH1. But there really is no MIH now.

I am not sure how to test this other than to wait for someone to send me spam.

I deleted some cookies a few days ago. Could that have something to do with this problem?

I changed the names of the accounts then went to SS then went to settings…apple mail tab…checked “select mailboxes to filter” chose the inboxes of the newly named accounts…then went back once… chose “filter now”. Guess what? It filtered out the spam mail!!

Does this mean that the problem is solved?

Is 60 seconds the right value for checking unread messages?

My mail boxes only have around 50 unread emails. So do I really need to cull through all of the read ones?

1 Like

I don’t think so.

Yes, it sounds like it.

Yes, I think 60 seconds is good unless you find that you are seeing unfiltered messages sit for a while in the inbox (without green flags, if you’ve enabled that option). Then you might want to make it faster. The large MIH INBOX that you have will probably slow it down more than waiting the 60 seconds between checks.

It’s the total number of messages that matters, because SpamSieve has to look at the whole message list to see which are unread. If you find that the filtering speed is fine and that Mail is still responsive, then you can leave it as-is.

Did you see my note—

Control command S does not work anymore (apple mail uses that for hide sidebar)

Is there a fix for this?

Please let me know whether the problem still occurs after you quit and relaunch Mail.

This is fixed in SpamSieve 3.0.1b1.

I don’t see this version when I “check for updates”. Is it coming out soon?

You can click the link for information about how to get the beta version.

With SpamSieve 3.0.1b2, renaming the “duplicate” accounts should no longer be necessary as long as one is disabled.